Do not accept SMTP server with underline character

VERIFIED INVALID

Status

Thunderbird
Account Manager
VERIFIED INVALID
10 years ago
9 years ago

People

(Reporter: Diogo Santos, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: closeme 2009-05-14)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; pt-BR; rv:1.9.0.2) Gecko/2008092313 Ubuntu/8.04 (hardy) Firefox/3.0.2
Build Identifier: Thunderbird 2.0.0.16

The SMTP server in my work is something like this: mail.lncc_adv.local (wiht the underline character).
In Windows Mail this function well, but in Thunderbird a have the message that this isn't a valid server.

How can I solve this?
Thanks

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
An underscore is not allowed in a domain name and that is the reason why Thunderbird rejects it.
You can workaround this if you use the IP of the server instead of the name.
Just open a commandline window and type "ping mail.lncc_adv.local" and you should get the IP.
Diogo : did Matti's trick helped ?
Whiteboard: closeme 2009-04-14
Whiteboard: closeme 2009-04-14 → closeme 2009-05-14
(Reporter)

Comment 3

9 years ago
Yeah, Matthias' trick solved the problem.
Thanks!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Resolution: FIXED → WORKSFORME
Resolution: WORKSFORME → INVALID
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.