Closed Bug 457113 Opened 12 years ago Closed 12 years ago

gnomestripe source files altered when building with --enable-chrome-format=symlink

Categories

(Firefox Build System :: General, defect)

x86
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: mnyromyr, Unassigned)

Details

(Keywords: regression)

Attachments

(1 file)

When building toolkit under Linux with --enable-chrome-format=symlink, the *source* files /mozilla/toolkit/themes/gnomestripe/global/autocomplete.css and /mozilla/toolkit/themes/gnomestripe/global/global.css are altered.

This is because gnomestripe is based upon winstripe, overriding some of its files. In particular:

Winstripe:
*       skin/classic/global/autocomplete.css
*       skin/classic/global/global.css

Gnomestripe:
+  skin/classic/global/autocomplete.css
+  skin/classic/global/global.css

Running make in gnomestripe will correctly provide a symlink to these files (now that bug 456466 is fixed), but during the *next* build run, making winstripe happens before and alters the symlinked source file (since preprocessed files obviously can't be symlinked)...
Attachment #340453 - Flags: review?(axel)
Attachment #340453 - Flags: review?(axel) → review?(l10n)
Comment on attachment 340453 [details] [diff] [review]
remove files and symlinks before writing them

Good catch, r=me.
Attachment #340453 - Flags: review?(l10n) → review+
Landed on trunk as <http://hg.mozilla.org/mozilla-central/rev/15ae5842b503>.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.