NEED proper separation of ALL user data (incl address book) for backup/restore

RESOLVED WORKSFORME

Status

--
enhancement
RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: prof, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.2) Gecko/2008092313 Ubuntu/8.04 (hardy) Firefox/3.0.2
Build Identifier: ALL

NEED easy/single sub-directory location for all mail user data (folders, POP status and address book.  Currently, Thunderbird by default buries your email data deep in meaningless directory names, in an area of the file system unlikely to be backed-up when backing up just user-data.  Let's not repeat this M$ fault of putting user data with programs.  Currently if you want your email data with your documents or home directory for ease of backing up your user-generated material, you need to change the sub-directory 'pointer' for where local folders are found AND you need to separately specify where the associated pop data is stored.  And even if you do these two 'duplicate' specifications of where your user data will be, you don't get your address book relocated to a location allowing easy backup.  I've backed up my Thunderbird folders etc, but have now lost my address book in a move from WinXP to Ubuntu.  It shouldn't have to be that hard.  Best to either install by default to 'home/documents/mail' in the case of Linux and 'My Documents\mail' in the case of Windows, so the stuff can be found by the average user and backed up more regularly than the whole system might be.  In a case where you find there are multiple users who might 'clash' in storing in a simple location, just ASK, rather than dreaming up unique long identifiers when 99.9% of people will not ever have any such crash... and the long/deep/complex sub-directories simply act to ensure that the data is not backed up.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.


Expected Results:  
A single clean location for all user-generated data (ie non-program bits).  Indeed best if even the file of the settings (config) for Thunderbird were also duplicated to this location.  Then if all goes back, all you should need to do is restore that directory within user 'home' area and install Thunderbird, and Thunderbird could search for and find such directory, and simply ask for you to confirm that you want to use those files/folders, and that way also recover its own config file which specified such paths, POP logins, SMTP etc.  Then upgrading from one computer to a new one would be a breeze, and upgrading from WinXP to Linux would also be a breeze.

Before you dismiss this as an 'unimportant' comment from a newbie, note I have 30 years IT experience.  I served as a Harvard consultant to The White House on IT policy.  I was on the team of five which developed the original spreadsheet at Harvard Business School in 1977-8 (though my classmate Dan Bricklin deserves all the credit as it was his idea and I was only doing design review).  I co-founded Australia's largest health informatics business.  I've also done significant reviews on user interface and development directions (eg see http://labs.divx.com/node/1067 for example).  I can be contacted on 'prof at-symbol post.harvard.edu'
the single clean location for all user-generated data is %APPDATA%\Thunderbird on windows and ~/.thunderbird (~/.mozilla-thunderbird on some debian/ubuntu builds) on linux.

http://kb.mozillazine.org/Profile_folder_-_Thunderbird
http://kb.mozillazine.org/Profile_backup
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
(Putting the data in a more user-visible place instead of the application user data locations as per platform conventions could be helpful in some cases to some extent, but most of those files are intended for use via the app; application settings and addressbook databases and whatnot files aren't usefully readable to an end user and would cause the app to misbehave if edited/moved/deleted, so having them clutter the user documents areas sounds like a risky proposition.)
(Reporter)

Comment 3

10 years ago
I understand Tuukka's points.
However, *.odt documents are ALSO intended to be opened by an application but they are in a 'user space' to be able to be backed up easily etc.  Email text logically isn't that different to word processing text.
But rather than discussing the issue of whether a parallel mind will ever meet, why not actually look at what happens in practice.  In practice, people back up their user data somewhat regularly, and whole-system backups are done seldom if ever...  'cause for Linux, if the OS is free, why bother to back it up?

So, it is agreed that changing from M$ Office to OpenOffice is easy BECAUSE all the data is in an agreed easy-to-find location.  But the minefield that is involved with changing over email apps is well-highlighted at
http://www.linux.com/feature/113798
and this is SMART users struggling with getting address book data across in particular.  The lesson is that the more you 'bury' such user-data down with the app's other settings, the more confusion and data loss that is caused whenever a change of app is required.

A reasonable compromise might be:
A. Ask at install time if users want their email data at:
   <long deep file location generated by Thunderbird>
 OR
   /home/<username>/mail
with a short explanatory note that the long/deep location is per standards but is admittedly outside the userspace they are likely to back-up regularly, while the second option might ensure that they back it up.  [NB: this keeps the files out of your WP docs but still within your userspace.]

B. Add the address book to same location (ie bring specification of three different locations for local folders, SMTP and address book to one (as specified in A above.  And even if you are a stickler for standards, perhaps at a minimum Thunderbird ought DUPLICATE the address book to CSV or other very open format in userspace (eg /home/<username>/ at the end of every Thunderbird session IFF the address book was updated during that session.  That way one would atleast put the addresses in a viewable/backupable location...

What SHOULD go under APP-DATA is settings that truly only make sense to the application, like whether people want to view mail in horizontal or vertical panes etc, as that data is TRULY a variable 'belonging to' the app (and valueless without the app).  However, user email files and address book data is NOT valueless outside the app, but indeed of great value, and worthy of backup.
In word processing, which languages are enabled for spell-checking etc are application data, and should be 'hidden', but documents and even mailing-merge address lists ARE kept in the open userspace area in editable form, which is the 'enlightened' way.  If we want a large majority of people to give up on M$ and switch to Linux, then we must make it easier and better, and repeating M$ type failings is not the answer.  But as the 1% player, Linux needs to make data migration REAL EASY, whereas the 90% player M$ is arguably better off with data/app migration remaining a nightmare, as it keeps people on M$ apps for fear of data loss and timewasting data recovery problems, of the type I've encountered in finally switching email from WinXP to Ubuntu (though Thunderbird to Thunderbird).
Graeme (prof at-symbol post.harvard.edu)
You need to log in before you can comment on or make changes to this bug.