Not displaying 8MB text attachment completely

CLOSED WORKSFORME

Status

MailNews Core
Networking: IMAP
P3
normal
CLOSED WORKSFORME
18 years ago
9 years ago

People

(Reporter: Karen Huang, Assigned: Scott MacGregor)

Tracking

Trunk
Future
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Used 07-17-09-M17 commercial build:

When trying to read message with a 8MB text attachment,
It's not displaying 8MB text attachment completely from the messages body and 
stop at 77%.

1) Login to an IMAP mail account.
2) Tried to read/receive an attached message with 8MB text attachment.
3) Actual Results: Not displaying 8MB text attachment completely from the 
messages body and stop at 77% on the status bar.

Expected results: Should display the 8MB text attachment completely from the 
message body.

P.S. I didn't find a existing bug for this problem, so just log for tracking 
this problem.

Updated

18 years ago
QA Contact: lchiang → pmock
Summary: Not displaying 8MB text attachment completely → Not displaying 8MB text attachment completely
reassign to rhp
Assignee: ducarroz → rhp

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → M18

Updated

18 years ago
Keywords: correctness, nsbeta3

Comment 2

18 years ago
Hmm....I tried this on a local folder and it worked...but I'll try IMAP from the
office tomorrow.

- rhp

Comment 3

18 years ago
Hi Scott,
I tried looking at a message like this from a local mail folder and it rendered 
fine, but I keep getting stuck on IMAP. 

- rhp
Assignee: rhp → mscott
Status: ASSIGNED → NEW
Component: Composition → Networking - IMAP

Updated

18 years ago
Keywords: mail2

Comment 4

18 years ago
Does this happen for other 8MB attachments such as a gif?  If it's only text,
then we'll minus this.  If it's every 8MB attachment of any type, then we'll
plus it.
Whiteboard: [b3 need info]

Comment 5

18 years ago
Karen, could you try this out with other types of attachments and let us know 
the results.
(Reporter)

Comment 6

18 years ago
I have tried to find it, but I couldn't find other 8MB gif attachments.
Peter, could you help for finding that? Thanks.
(Reporter)

Comment 7

18 years ago
By using the 08-15-08-M18 commercial build for new profile:
Attched a 5.5 MB jpg file -- progress bar will complete at 100% and the 
image will display completely.
Attached the 9.3 MB jpg file -- From the progress bar, it stop at 80%, but the 
file seems display completely.
Thanks Peter for helping for those jpg files.
(Reporter)

Comment 8

18 years ago
provided info -- clear status whiteboard [b3 need info].
Whiteboard: [b3 need info]

Comment 9

18 years ago
works fine per other attachments.  Perhaps just isolated to this case.
- per mail triage
Whiteboard: [nsbeta3-]

Comment 10

17 years ago
sorry for the extra email. Removing mail2 keyword.
Keywords: mail2

Comment 11

17 years ago
adding mail3 keyword. this is important to fix, if it's some sort of race
condition or other architectural problem exposed by the large size of the attachment
Keywords: nsbeta3 → mail3

Comment 12

17 years ago
marking nsbeta1+ and moving to mozilla0.8
Keywords: nsbeta1
Whiteboard: [nsbeta3-] → [nsbeta1+]
Target Milestone: M18 → mozilla0.8

Comment 13

17 years ago
marking nsbeta1-
Keywords: nsbeta1 → nsbeta1-
Whiteboard: [nsbeta1+] → [nsbeta1+ 1/25]
Target Milestone: mozilla0.8 → Future

Comment 14

17 years ago
Assign it to myself.
QA Contact: pmock → fenella

Comment 15

17 years ago
To Esther..
QA Contact: fenella → esther

Comment 16

17 years ago
I think this is a dupe of bug 63162. Which was fixed just today. Thoughts?

Comment 17

17 years ago
doubtful - I believe the necko change that introduced that bug was long after
this bug was reported.
(Assignee)

Comment 18

17 years ago
getting off my beta1+ search list...
Whiteboard: [nsbeta1+ 1/25]

Comment 19

16 years ago
is this an issue. If so please attach a IMAP log with the problem...

Comment 20

16 years ago
Not only depend on the size see this problem also with smaler attachments.
I think its depending on the content. Also saving some Word document's don't
work Proberly only partial contents was saved.

Comment 21

16 years ago
could this be dupe of 105606 or the other way around?

Updated

16 years ago
QA Contact: esther → trix

Comment 22

15 years ago
works for me
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Comment 23

15 years ago
close it
Status: RESOLVED → CLOSED

Comment 24

15 years ago
dont close bugs...! you can mark it worksforme

what kind of server did you test against, and what kind of server did the bug
original be reported against?

If it's Exchange then this bug is dupe of bug 105606
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.