Thunderbird 2.0.0.17 en-US win32 not downloadable, download link always redirects to list with files for different OS and containing Firefox downloads, if javascript disabled

RESOLVED FIXED

Status

www.mozilla.org
General
--
major
RESOLVED FIXED
10 years ago
6 years ago

People

(Reporter: aryx, Assigned: clouserw)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

Thunderbird 2.0.0.1 7 en-US win32 download link redirects to list with files for different OS

1. Go to http://www.mozilla.com/en-US/thunderbird/all.html
2. Click at the en-US windows link.

Actual result:
A page with Firefox and Thunderbird download links for different operating systems is shown.
There it also redirects, so en-US isn't downloadable for me (changing the page language to English offers en-GB).
Severity: minor → major
Summary: Thunderbird 2.0.0.1 7 en-US win32 download link redirects to list with files for different OS → Thunderbird 2.0.0.17 en-US win32 not downloadable, download link always redirects to list with files for different OS and containing Firefox downloads
I'm not seeing this... Can you post some screenshots? Do you have JS disabled/enabled?
It works fine if JavaScript is enabled and fails if JavaScript is disabled (had no problems downloading the en-US builds in the past). Attached screenshot thanks for downloading Firefox
Summary: Thunderbird 2.0.0.17 en-US win32 not downloadable, download link always redirects to list with files for different OS and containing Firefox downloads → Thunderbird 2.0.0.17 en-US win32 not downloadable, download link always redirects to list with files for different OS and containing Firefox downloads, if javascript disabled
I can reproduce; Wil, thoughts/ideas/patches? :-)
Perhaps this qualifies as a separate bug, but actually there are also problems with downloading Firefox, too.
Steps to reproduce:
1) disable JavaScript
2) go to http://www.mozilla.com/en-US/firefox/all.html
3) click on "Download" link in "English (US)" line (I tested Linux and Windows)
4) you will go to http://www.mozilla.com/en-US/products/download.html?product=firefox-3.0.6&os=win&lang=en-US but after manually choosing again it does nothing (reloads page).
(Assignee)

Comment 7

10 years ago
Both bugs are the same and fixed in r22395.
Assignee: nobody → clouserw
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Verified FIXED on https://www-trunk.stage.mozilla.com/en-US/products/download.html?product=firefox-3.0.6&os=win&lang=en-US; someone will have to push these changes to prod, I'm guessing?
(Assignee)

Comment 9

10 years ago
This is on trunk and stage but it looks like it's caught up in the middle of the FF3.1 changes so it isn't live yet.
Reopening, I still see this with Firefox 3.5.7 and en-US from the all versions page.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 11

9 years ago
This bug is a year old and still fixed on mozilla.com.  If you follow the steps in comment 0 the bug does exist, but it's on mozillamessaging.com and has different maintainers.  Please open a new bug (or clone this one) in that component.
Status: REOPENED → RESOLVED
Last Resolved: 10 years ago9 years ago
Resolution: --- → FIXED
Component: www.mozilla.org/firefox → www.mozilla.org
Product: Websites → Websites
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.