Event Special Instance Alarm Will Not Dismiss/Dismiss All

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
10 years ago
9 years ago

People

(Reporter: citrusmoose, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.2) Gecko/2008091620 Firefox/3.0.2 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.18pre) Gecko/20080917 Sunbird/0.9

I have a recurring event with an alarm (Mondays at 10am).  An instance of this event has been moved to the following day (Tuesday, Sept 2, 2008), and the alarm for that instance will not dismiss/dismiss all.  I have to close the reminder box using the X button, but the reminder keeps popping up a few minutes later (I'm assuming it's snoozing).  I've even tried deleting the instance, editing the ICS file to delete the EXDATE under the event, and then creating the special instance (moving it to Tuesday) again in Lightning just to make sure it didn't get corrupted somehow.  There's other special instances earlier than this one if that matters.  I'm attaching a sample ICS file that has the problem.  The ICS file is accessed via Apache/WebDAV.

Reproducible: Always

Steps to Reproduce:
1. Subscribe to the attached file (Test.ics) with the default options.
Actual Results:  
An alarm for September 2, 2008 appears in the reminders dialog box.  I cannot dismiss the alarm by clicking on the Dismiss or Dismiss All buttons.  I can snooze by closing the dialog box or by hitting the either of the snooze options.  The alarm, of course, appears later after the specified snooze time expires.

Expected Results:  
I should be able to dismiss the alarm.

No errors seem to appear in the Error Console when I try to dismiss the alarm.  My alarm options are as follows:  'Play a sound', 'Show an alarm box', and 'Show missed alarms' are selected.  'Default alarm setting for events/tasks' are both 'On'.  Both default times are 15 minutes.
(Reporter)

Comment 1

10 years ago
Created attachment 340581 [details]
Event Special Instance Alarm Example
Attachment #340581 - Attachment mime type: text/calendar → text/plain

Comment 2

10 years ago
confirmed 

I also had the problem at some stage I could do a remind me in a far far away time (like in 100 day) so it doesn't annoy me for a time but now I cannot even do that and I just have to support that alarm popping every some (to short) time

Updated

10 years ago
Flags: blocking-calendar1.0?

Comment 3

10 years ago
I've got this error in the error console :
Erreur : [Exception... "'<error>' when calling method: [calICalendar::modifyItem]"  nsresult: "0x804a0002 (<unknown>)"  location: "JS frame :: file:///E:/appdata/thuderbird/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calItemModule.js -> file:///E:/appdata/thuderbird/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calAlarmService.js :: cas_dismissAlarm :: line 247"  data: no]
Fichier source : file:///E:/appdata/thuderbird/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calItemModule.js -> file:///E:/appdata/thuderbird/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calAlarmService.js
Ligne : 247

also want to add that I'm on lightning 0.9 with windows vista I'll try to check asap if it does the same on linux
(In reply to comment #3)

Error 0x804a0002 is CAL_IS_READONLY. Snoozing or dismissing alarms requires write access to the calendar. Therefore it fails if the calendar is set to read-only. See Bug 356002.

Comment 5

10 years ago
(In reply to comment #4)
> (In reply to comment #3)
> 
> Error 0x804a0002 is CAL_IS_READONLY. Snoozing or dismissing alarms requires
> write access to the calendar. Therefore it fails if the calendar is set to
> read-only. See Bug 356002.

well I agree that it's because of that bug that we (I) cannot dismiss the alarm, but every time I try to dismiss it the cal is change to read only and I've to change it every time if I want to change some thing. that append only when trying to dismiss a special instance so maybe the fact that we cannot dismiss alarm is visible because of the read only access but the fact is that I don't choose to be in read only and it's not read only except when I want to dismiss that instance 

I work with a local .ics file where I have all access right (since I can do new event and change them on the very same calendar.)
(Reporter)

Comment 6

10 years ago
My calendar is not read-only.  I can snooze/dismiss any other alarm.

Updated

10 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All

Comment 7

10 years ago
I haven't been able to dismiss alarms for 5 days. I can see this error:
Error: An error occurred when writing to the calendar Cal! Error code: MODIFICATION_FAILED. Description: 
Source File: file:///C:/Users/Omar/AppData/Roaming/Thunderbird/Profiles/24a9rrqc.Omar/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calUtils.jsm -> file:///C:/Users/Omar/AppData/Roaming/Thunderbird/Profiles/24a9rrqc.Omar/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calCalendarManager.js
Line: 890

Comment 8

9 years ago
the issue seam to be solved on 1pre for recurring event that have bean created on 1pre, the one created on .9 still cannot be dismissed

I think the step to reproduce the bug is (or well what I did to try reproduce it would need to check if it does on .9):
1. create a recurring event the have at least 4 occurrence and alarm set
2. after the first occurrence is passed and dismissed change the 3 occurrence name and category
3. dismiss the second when you can
4. snooze the 3 so that you dismiss it only after the event is finish
5. see if it pop you

it's what is the closest to how I did create the bug in normal life (the real situation was that I've 15 weekly occurrence of a class that I take, when an exam is scheduled I say it in the name and change to category Exam)

but has I say with 1pre I don't have the problem anymore. and the old alarm (from .9) can be "dismissed" by removing the alarm in the event edit dialog
Unfortunately I can't reproduce this bug. Maybe you can attach the 0.9 event that fails on this bug. Also, bug 494140 may fix this issue for those of you using storage calendars.

I'm marking this bug as wfm for now, please reopen if the problem persists after bug 494140.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 10

9 years ago
I just downloaded the latest sunbird nightly.  It does seem to be fixed (at least for non-storage calendars).
Flags: blocking-calendar1.0?
You need to log in before you can comment on or make changes to this bug.