Last Comment Bug 457242 - Change the Songbird blog feed URL
: Change the Songbird blog feed URL
Status: RESOLVED FIXED
:
Product: Websites
Classification: Other
Component: planet.mozilla.org (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Robert Accettura [:raccettura]
:
:
Mentors:
http://planet.mozilla.org
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-26 08:48 PDT by Stephen Lau
Modified: 2009-01-18 11:28 PST (History)
7 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Stephen Lau 2008-09-26 08:48:47 PDT
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.2) Gecko/2008091618 Firefox/3.0.2
Build Identifier: 

(I work at Songbird)
Right now our Twitter posts get mirrored to our blog; while we want our regular direct subscribers to see these - we'd rather not clutter up p.m.o. with them.  Could you change the subscription feed for the Songbird Blog to:

http://www.feedrinse.com/services/rinse/?rinsedurl=7c2bfea4ba4500437fd8e6f3c2137bbb

This is a filtered feed that is the same as our blog feed minus the Twitter posts.

Thanks!
stevel

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Comment 1 Stephen Lau 2008-09-26 08:50:02 PDT
Feel free to confirm at my Songbird email (stevel@songbirdnest.com) if you need to verify that I'm a Songbird employee.  :)
Comment 2 Asa Dotzler [:asa] 2008-09-26 12:08:03 PDT
Robert or Reed, can one of you please make this change ASAP? Thanks!
Comment 3 Reed Loden [:reed] (use needinfo?) 2008-09-26 12:29:06 PDT
Changed.

Sending        config.ini
Transmitting file data .
Committed revision 18704.
Comment 4 Stephen Lau 2008-09-29 09:42:26 PDT
thanks Reed!
Comment 5 Stephen Lau 2008-10-29 10:28:04 PDT
This seems to have reverted back to blog.songbirdnest.com from our feedrinse.com feed URL above.

Could we get it re-updated to the feedrinse URL?
Comment 6 Reed Loden [:reed] (use needinfo?) 2008-10-29 10:33:27 PDT
(In reply to comment #5)
> This seems to have reverted back to blog.songbirdnest.com from our
> feedrinse.com feed URL above.
> 
> Could we get it re-updated to the feedrinse URL?

[http://www.feedrinse.com/services/rinse/?rinsedurl=7c2bfea4ba4500437fd8e6f3c2137bbb]
name = Songbird

Still using the feedrinse URL... What makes you think it's using the other URL?
Comment 7 Stephen Lau 2008-10-29 10:56:49 PDT
(In reply to comment #6)
> Still using the feedrinse URL... What makes you think it's using the other URL?

Hrm, I still see our Twitter posts on PMO as of this morning (search for 'Songbirdteam Tweets for the week of 2008-10-26' and you'll see it).  The Twitter post only shows up in our blog.sbn.c feed, and not our feedrinse feed.

I assumed it had reverted to the blog.songbirdnest.com feed since the URL on the right sidebar was directed to blog.songbirdnest.com instead of feedrinse.
Comment 8 Phil Ringnalda (:philor) 2008-10-29 11:25:06 PDT
Since the "<atom:link href="http://blog.songbirdnest.com/feed/" rel="self" type="application/rss+xml" />" in http://www.feedrinse.com/services/rinse/?rinsedurl=7c2bfea4ba4500437fd8e6f3c2137bbb says "the one true and correct URL to fetch the content you just fetched is http://blog.songbirdnest.com/feed/ rather than what you used" it wouldn't surprise me if Venus does just that (though a quick look at the code didn't tell me where it does, if it does).
Comment 9 Stephen Lau 2008-10-29 11:51:56 PDT
hrm, ideally Venus would pull the feed entries & content from the URL configured (feedrinse, in this case), but in the right sidebar, the link to the actual blog would be the canonical URL in the feed.

But yeah, I've no idea what or how Venus is actually doing it.
Comment 10 Stephen Lau 2008-12-18 13:24:27 PST
Hi, I think we've found a better plan.... could we drop the umbrella "Songbird Blog" feed in favour of author feeds?  I'd rather see our individual posts as separate authors rather than the currently-anonymous-seeming "Songbird Blog", and this would remove problems like our Twitter posts, etc.

This would entail removing http://blog.songbirdnest.com (or http://www.feedrinse.com/services/rinse/?rinsedurl=7c2bfea4ba4500437fd8e6f3c2137bbb) if it's using the feedrinse URL from your config and adding:

Ali Rayl
http://blog.songbirdnest.com/author/ali/?feed=atom

Ghislain 'Aus' Lacroix
http://blog.songbirdnest.com/author/aus/?feed=atom

David Bradley
http://blog.songbirdnest.com/author/dbradley/?feed=atom

Georges Auberger
http://blog.songbirdnest.com/author/georges/?feed=atom

Jan Leger
http://blog.songbirdnest.com/author/jleger/?feed=atom

Francis Gastellu
http://blog.songbirdnest.com/author/lone/?feed=atom

Matt Crocker
http://blog.songbirdnest.com/author/matt/?feed=atom

Mike Smith
http://blog.songbirdnest.com/author/msmith/?feed=atom

J. Paul Reed
http://blog.songbirdnest.com/author/preed/?feed=atom

John Gaunt
http://blog.songbirdnest.com/author/redfive/?feed=atom

Rob Lord
http://blog.songbirdnest.com/author/roblord/?feed=atom

Ryan Tomayko
http://blog.songbirdnest.com/author/rtomayko/?feed=atom
Comment 11 Reed Loden [:reed] (use needinfo?) 2009-01-08 13:04:14 PST
Asa, racettura, and dria: ok to swap out one feed url and replace with 12 feeds?
Comment 12 Stephen Lau 2009-01-08 13:08:07 PST
You can drop preed's feed from that list, he'll just blog on his existing blog that is pulled into PMO already.
Comment 13 Asa Dotzler [:asa] 2009-01-16 15:57:03 PST
yeah. i'd like that. a=asa
Comment 14 Stephen Lau 2009-01-18 11:28:22 PST
thanks!!

Note You need to log in before you can comment on or make changes to this bug.