Can't use mail in mac classic skin, infinite loop

VERIFIED DUPLICATE of bug 45336

Status

P3
critical
VERIFIED DUPLICATE of bug 45336
19 years ago
11 years ago

People

(Reporter: mikepinkerton, Assigned: mikepinkerton)

Tracking

({crash})

Trunk
PowerPC
Mac System 9.x
crash

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+])

Try to read mail (IMAP) with the mac classic skin and you get an infinite loop:

 Calling chain using A6/R1 links
  Back chain  ISA  Caller
  00000000    PPC  13D2B2B8  
  14D4EE00    PPC  13D11034  main+001AC
  14D4ED90    PPC  13D0E754  main1(int, char**, nsISupports*)+00994
  14D4EB10    PPC  138FC534  nsAppShellService::Run()+00054
  14D4EAC0    PPC  13694B8C  nsAppShell::Run()+00040
  14D4EA80    PPC  1369543C  nsMacMessagePump::DoMessagePump()+00044
  14D4EA30    PPC  13695C68  nsMacMessagePump::DispatchEvent(int, EventRecord*)+
001B0
  14D4E9E0    PPC  136B7BEC  Repeater::DoRepeaters(const EventRecord&)+0003C
  14D4E990    PPC  136649B8  nsMacNSPREventQueueHandler::RepeatAction(const 
EventRecord&)+000
14
  14D4E950    PPC  13664B88  nsMacNSPREventQueueHandler::ProcessPLEventQueue()+
00168
  14D4E8E0    PPC  13B7AAB8  nsEventQueueImpl::ProcessPendingEvents()+00068
  14D4E870    PPC  13BF6194  PL_ProcessPendingEvents+00084
  14D4E820    PPC  13BF62D8  PL_HandleEvent+00054
  14D4E7E0    PPC  12DECE9C  HandlePLEvent(ReflowEvent*)+000D4
  14D4E780    PPC  12DEDD60  PresShell::ProcessReflowCommands(int)+005A4
  14D4E670    PPC  12DE9E84  PresShell::HandlePostedReflowCallbacks()+000BC
  14D4E620    PPC  12DEA140  PresShell::FlushPendingNotifications()+00028
  14D4E5E0    PPC  12DEDD60  PresShell::ProcessReflowCommands(int)+005A4
  14D4E4D0    PPC  12DE9E84  PresShell::HandlePostedReflowCallbacks()+000BC
  14D4E480    PPC  12DEA140  PresShell::FlushPendingNotifications()+00028
  14D4E440    PPC  12DEDD60  PresShell::ProcessReflowCommands(int)+005A4
  14D4E330    PPC  12DE9E84  PresShell::HandlePostedReflowCallbacks()+000BC
  14D4E2E0    PPC  12DEA140  PresShell::FlushPendingNotifications()+00028
  14D4E2A0    PPC  12DEDD60  PresShell::ProcessReflowCommands(int)+005A4
  14D4E190    PPC  12DE9E84  PresShell::HandlePostedReflowCallbacks()+000BC
  14D4E140    PPC  12DEA140  PresShell::FlushPendingNotifications()+00028
  14D4E100    PPC  12DEDD60  PresShell::ProcessReflowCommands(int)+005A4
  14D4DFF0    PPC  12DE9E84  PresShell::HandlePostedReflowCallbacks()+000BC
  14D4DFA0    PPC  12DEA140  PresShell::FlushPendingNotifications()+00028
  14D4DF60    PPC  12DEDD60  PresShell::ProcessReflowCommands(int)+005A4
  14D4DE50    PPC  12DE9E84  PresShell::HandlePostedReflowCallbacks()+000BC
  14D4DE00    PPC  12DEA140  PresShell::FlushPendingNotifications()+00028
  14D4DDC0    PPC  12DEDD60  PresShell::ProcessReflowCommands(int)+005A4
  14D4DCB0    PPC  12DE9E84  PresShell::HandlePostedReflowCallbacks()+000BC
  14D4DC60    PPC  12DEA140  PresShell::FlushPendingNotifications()+00028
  14D4DC20    PPC  12DEDD60  PresShell::ProcessReflowCommands(int)+005A4
  14D4DB10    PPC  12DE9E84  PresShell::HandlePostedReflowCallbacks()+000BC
  14D4DAC0    PPC  12DEA140  PresShell::FlushPendingNotifications()+00028
  14D4DA80    PPC  12DEDD60  PresShell::ProcessReflowCommands(int)+005A4
  14D4D970    PPC  12DE9E84  PresShell::HandlePostedReflowCallbacks()+000BC
  14D4D920    PPC  12DEA140  PresShell::FlushPendingNotifications()+00028
  14D4D8E0    PPC  12DEDD60  PresShell::ProcessReflowCommands(int)+005A4
  14D4D7D0    PPC  12DE9E84  PresShell::HandlePostedReflowCallbacks()+000BC
  14D4D780    PPC  12DEA140  PresShell::FlushPendingNotifications()+00028
  14D4D740    PPC  12DEDD60  PresShell::ProcessReflowCommands(int)+005A4
  14D4D630    PPC  12DE9E84  PresShell::HandlePostedReflowCallbacks()+000BC
  14D4D5E0    PPC  12DEA140  PresShell::FlushPendingNotifications()+00028
  14D4D5A0    PPC  12DEDD60  PresShell::ProcessReflowCommands(int)+005A4
  14D4D490    PPC  12DE9E84  PresShell::HandlePostedReflowCallbacks()+000BC
  14D4D440    PPC  12DEA140  PresShell::FlushPendingNotifications()+00028
  14D4D400    PPC  12DEDD60  PresShell::ProcessReflowCommands(int)+005A4
  14D4D2F0    PPC  12DE9E84  PresShell::HandlePostedReflowCallbacks()+000BC
  14D4D2A0    PPC  12DEA140  PresShell::FlushPendingNotifications()+00028
  14D4D260    PPC  12DEDD60  PresShell::ProcessReflowCommands(int)+005A4
  14D4D150    PPC  12DE9E84  PresShell::HandlePostedReflowCallbacks()+000BC
  14D4D100    PPC  12DEA140  PresShell::FlushPendingNotifications()+00028
  14D4D0C0    PPC  12DEDD60  PresShell::ProcessReflowCommands(int)+005A4
  14D4CFB0    PPC  12DE9E84  PresShell::HandlePostedReflowCallbacks()+000BC
  14D4CF60    PPC  12DEA140  PresShell::FlushPendingNotifications()+00028
  14D4CF20    PPC  12DEDD60  PresShell::ProcessReflowCommands(int)+005A4
  14D4CE10    PPC  12DE9E84  PresShell::HandlePostedReflowCallbacks()+000BC
  14D4CDC0    PPC  12DEA140  PresShell::FlushPendingNotifications()+00028
  14D4CD80    PPC  12DEDD60  PresShell::ProcessReflowCommands(int)+005A4
  14D4CC70    PPC  12DE9E84  PresShell::HandlePostedReflowCallbacks()+000BC
  14D4CC20    PPC  12DEA140  PresShell::FlushPendingNotifications()+00028
  14D4CBE0    PPC  12DEDD60  PresShell::ProcessReflowCommands(int)+005A4
  14D4CAD0    PPC  12DE9E84  PresShell::HandlePostedReflowCallbacks()+000BC
  14D4CA80    PPC  12DEA140  PresShell::FlushPendingNotifications()+00028
  14D4CA40    PPC  12DEDD60  PresShell::ProcessReflowCommands(int)+005A4
  14D4C930    PPC  12DE9E84  PresShell::HandlePostedReflowCallbacks()+000BC
  14D4C8E0    PPC  12DEA140  PresShell::FlushPendingNotifications()+00028
  14D4C8A0    PPC  12DEDD60  PresShell::ProcessReflowCommands(int)+005A4
  14D4C790    PPC  12DE9E84  PresShell::HandlePostedReflowCallbacks()+000BC
  14D4C740    PPC  12DEA140  PresShell::FlushPendingNotifications()+00028
  14D4C700    PPC  12DEDD60  PresShell::ProcessReflowCommands(int)+005A4
  14D4C5F0    PPC  12DE9E84  PresShell::HandlePostedReflowCallbacks()+000BC
  14D4C5A0    PPC  12DEA140  PresShell::FlushPendingNotifications()+00028
  14D4C560    PPC  12DEDD60  PresShell::ProcessReflowCommands(int)+005A4
  14D4C450    PPC  12DE9E84  PresShell::HandlePostedReflowCallbacks()+000BC
  14D4C400    PPC  12DEA140  PresShell::FlushPendingNotifications()+00028
  14D4C3C0    PPC  12DEDD60  PresShell::ProcessReflowCommands(int)+005A4
  14D4C2B0    PPC  12DE9E84  PresShell::HandlePostedReflowCallbacks()+000BC
  14D4C260    PPC  12DEA140  PresShell::FlushPendingNotifications()+00028
  14D4C220    PPC  12DEDD60  PresShell::ProcessReflowCommands(int)+005A4
  14D4C110    PPC  12DE9E84  PresShell::HandlePostedReflowCallbacks()+000BC
  14D4C0C0    PPC  12DEA140  PresShell::FlushPendingNotifications()+00028
  14D4C080    PPC  12DEDD60  PresShell::ProcessReflowCommands(int)+005A4
  14D4BF70    PPC  12DE9E84  PresShell::HandlePostedReflowCallbacks()+000BC
  14D4BF20    PPC  12DEA140  PresShell::FlushPendingNotifications()+00028
  14D4BEE0    PPC  12DEDD60  PresShell::ProcessReflowCommands(int)+005A4
  14D4BDD0    PPC  12DE9E84  PresShell::HandlePostedReflowCallbacks()+000BC
  14D4BD80    PPC  12DEA140  PresShell::FlushPendingNotifications()+00028
  14D4BD40    PPC  12DEDD60  PresShell::ProcessReflowCommands(int)+005A4
  14D4BC30    PPC  12DE9E84  PresShell::HandlePostedReflowCallbacks()+000BC
  14D4BBE0    PPC  12DEA140  PresShell::FlushPendingNotifications()+00028
  14D4BBA0    PPC  12DEDD60  PresShell::ProcessReflowCommands(int)+005A4
  14D4BA90    PPC  12DE9E84  PresShell::HandlePostedReflowCallbacks()+000BC
  14D4BA40    PPC  12DEA140  PresShell::FlushPendingNotifications()+00028
  14D4BA00    PPC  12DEDD60  PresShell::ProcessReflowCommands(int)+005A4
  14D4B8F0    PPC  12DE9E84  PresShell::HandlePostedReflowCallbacks()+000BC
  14D4B8A0    PPC  12DEA140  PresShell::FlushPendingNotifications()+00028
  14D4B860    PPC  12DEDD60  PresShell::ProcessReflowCommands(int)+005A4
  14D4B750    PPC  12DE9E84  PresShell::HandlePostedReflowCallbacks()+000BC
  14D4B700    PPC  12DEA140  PresShell::FlushPendingNotifications()+00028
  14D4B6C0    PPC  12DEDD60  PresShell::ProcessReflowCommands(int)+005A4
  14D4B5B0    PPC  12DE9E84  PresShell::HandlePostedReflowCallbacks()+000BC
  14D4B560    PPC  12DEA140  PresShell::FlushPendingNotifications()+00028
  14D4B520    PPC  12DEDD60  PresShell::ProcessReflowCommands(int)+005A4
  14D4B410    PPC  12DE9E84  PresShell::HandlePostedReflowCallbacks()+000BC
  14D4B3C0    PPC  12DEA140  PresShell::FlushPendingNotifications()+00028
  14D4B380    PPC  12DEDD60  PresShell::ProcessReflowCommands(int)+005A4
  14D4B270    PPC  12DE9E84  PresShell::HandlePostedReflowCallbacks()+000BC
  14D4B220    PPC  12DEA140  PresShell::FlushPendingNotifications()+00028
  14D4B1E0    PPC  12DEDD60  PresShell::ProcessReflowCommands(int)+005A4
  14D4B0D0    PPC  12DE9E84  PresShell::HandlePostedReflowCallbacks()+000BC
  14D4B080    PPC  12DEA140  PresShell::FlushPendingNotifications()+00028
  14D4B040    PPC  12DEDD60  PresShell::ProcessReflowCommands(int)+005A4
  14D4AF30    PPC  12DE9E84  PresShell::HandlePostedReflowCallbacks()+000BC
  14D4AEE0    PPC  12DEA140  PresShell::FlushPendingNotifications()+00028
  14D4AEA0    PPC  12DEDD60  PresShell::ProcessReflowCommands(int)+005A4
  14D4AD90    PPC  12DE9E84  PresShell::HandlePostedReflowCallbacks()+000BC
  14D4AD40    PPC  12DEA140  PresShell::FlushPendingNotifications()+00028
  14D4AD00    PPC  12DEDD60  PresShell::ProcessReflowCommands(int)+005A4
  14D4ABF0    PPC  12DE9E84  PresShell::HandlePostedReflowCallbacks()+000BC
  14D4ABA0    PPC  12DEA140  PresShell::FlushPendingNotifications()+00028
  14D4AB60    PPC  12DEDD60  PresShell::ProcessReflowCommands(int)+005A4
  14D4AA50    PPC  12DE9E84  PresShell::HandlePostedReflowCallbacks()+000BC
  14D4AA00    PPC  12DEA140  PresShell::FlushPendingNotifications()+00028
  14D4A9C0    PPC  12DEDD60  PresShell::ProcessReflowCommands(int)+005A4
  14D4A8B0    PPC  12DE9E84  PresShell::HandlePostedReflowCallbacks()+000BC
  14D4A860    PPC  12DEA140  PresShell::FlushPendingNotifications()+00028
  14D4A820    PPC  12DEDD60  PresShell::ProcessReflowCommands(int)+005A4
  14D4A710    PPC  12DE9E84  PresShell::HandlePostedReflowCallbacks()+000BC
  14D4A6C0    PPC  12DEA140  PresShell::FlushPendingNotifications()+00028
  14D4A680    PPC  12DEDD60  PresShell::ProcessReflowCommands(int)+005A4
  14D4A570    PPC  12DE9E84  PresShell::HandlePostedReflowCallbacks()+000BC
  14D4A520    PPC  12DEA140  PresShell::FlushPendingNotifications()+00028
  14D4A4E0    PPC  12DEDD60  PresShell::ProcessReflowCommands(int)+005A4
  14D4A3D0    PPC  12DE9E84  PresShell::HandlePostedReflowCallbacks()+000BC
  14D4A380    PPC  12DEA140  PresShell::FlushPendingNotifications()+00028
  14D4A340    PPC  12DEDD60  PresShell::ProcessReflowCommands(int)+005A4
  14D4A230    PPC  12DE9E84  PresShell::HandlePostedReflowCallbacks()+000BC
  14D4A1E0    PPC  12DEA140  PresShell::FlushPendingNotifications()+00028
  14D4A1A0    PPC  12DEDD60  PresShell::ProcessReflowCommands(int)+005A4
  14D4A090    PPC  12DE9E84  PresShell::HandlePostedReflowCallbacks()+000BC
  14D4A040    PPC  12DEA140  PresShell::FlushPendingNotifications()+00028
  14D4A000    PPC  12DEDD60  PresShell::ProcessReflowCommands(int)+005A4
  14D49EF0    PPC  12DE9E84  PresShell::HandlePostedReflowCallbacks()+000BC
  14D49EA0    PPC  12DEA140  PresShell::FlushPendingNotifications()+00028
  14D49E60    PPC  12DEDD60  PresShell::ProcessReflowCommands(int)+005A4
  14D49D50    PPC  12DE9E84  PresShell::HandlePostedReflowCallbacks()+000BC
  14D49D00    PPC  12DEA140  PresShell::FlushPendingNotifications()+00028
  14D49CC0    PPC  12DEDD60  PresShell::ProcessReflowCommands(int)+005A4
  14D49BB0    PPC  12DE9E84  PresShell::HandlePostedReflowCallbacks()+000BC
  14D49B60    PPC  12DEA140  PresShell::FlushPendingNotifications()+00028
  14D49B20    PPC  12DEDD60  PresShell::ProcessReflowCommands(int)+005A4
  14D49A10    PPC  12DE9E84  PresShell::HandlePostedReflowCallbacks()+000BC
  14D499C0    PPC  12DEA140  PresShell::FlushPendingNotifications()+00028
  14D49980    PPC  12DEDD60  PresShell::ProcessReflowCommands(int)+005A4
  14D49870    PPC  12DE9E84  PresShell::HandlePostedReflowCallbacks()+000BC
  14D49820    PPC  12DEA140  PresShell::FlushPendingNotifications()+00028
  14D497E0    PPC  12DEDD60  PresShell::ProcessReflowCommands(int)+005A4
  14D496D0    PPC  12DE9E84  PresShell::HandlePostedReflowCallbacks()+000BC
  14D49680    PPC  12DEA140  PresShell::FlushPendingNotifications()+00028
  14D49640    PPC  12DEDD60  PresShell::ProcessReflowCommands(int)+005A4
 Closing log
this makes mail unusable with the classic skin. marking beta2.
Keywords: crash, nsbeta2

Comment 2

19 years ago
cc lchiang and hangas

Comment 3

19 years ago
This is probably a duplicate of bug:
http://bugzilla.mozilla.org/show_bug.cgi?id=45336
So what is exactly happening here?  Is Mail unable to launch?  Or can you 
just not check IMAP mail after launch?
mail launches, but it hangs scrolling the folder pane or checking email (imap)
This bug is definitely different from bug #45336. This bug is not just caused by 
scrollbars either, but by clicking on widgets such as arrow twisties as well.  
The app locks up, and is entirely unusable.

Updated

19 years ago
Status: NEW → ASSIGNED

Comment 7

19 years ago
Putting on [nsbeta2+] radar for beta2 fix. 
Assignee: nbhatla → nisheeth
Status: ASSIGNED → NEW
Whiteboard: [nsbeta2+]

Comment 8

19 years ago
*** Bug 45925 has been marked as a duplicate of this bug. ***

Comment 9

19 years ago
Hyatt, Mike, and I took a look at this on Mike's Mac today.  We've 
narrowed down the problem to the line of CSS in messenger.css that includes 
sidebar.css.  Hyatt and Mike will look at this more tomorrow.  Mike has agreed 
to own this bug, so, re-assigning to him.
Assignee: nisheeth → pinkerton

Comment 10

19 years ago
In bug 45925, Nikhil narrowed down the crash to a 'border-top' declaration within 
sidebar.css.

Comment 11

19 years ago
I think this is a dup of bug 45336, since both stem from a problem in 
sidebar.css.   Nikhil checked in a fix for 45336, so I'll reopen this if it 
still doesn't work.

*** This bug has been marked as a duplicate of 45336 ***
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 12

19 years ago
Yeppp..marking Verified as a dup
Status: RESOLVED → VERIFIED

Comment 13

14 years ago
fixing null OS field on old bugs
OS: Mac System 9.x
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.