Download manager doesn't show new items when restored from closed state

RESOLVED WORKSFORME

Status

()

Toolkit
Downloads API
RESOLVED WORKSFORME
10 years ago
7 years ago

People

(Reporter: misterx42, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; cs; rv:1.9.0.2) Gecko/2008091620 Firefox/3.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; cs; rv:1.9.0.2) Gecko/2008091620 Firefox/3.0.2

I noticed that when I close the download manager and then download new file, the file doesn't show when window is restored. Furthermore, after closing the manager and downloading another file, files that were downloaded in the meantime are deleted from the list. It however happens only in some sessions - when I tried to open new window and download some file, it worked correctly, so my apologies if this isn't bug and shouldn't be pointed out.

Reproducible: Sometimes

Steps to Reproduce:
1. Open new tab
2. Download any file
Actual Results:  
Download manager didn't refresh.

Expected Results:  
Download manager should show new downloaded item.
(Reporter)

Updated

10 years ago
Version: unspecified → 3.0 Branch

Updated

9 years ago
Component: File Handling → Download Manager
Product: Firefox → Toolkit
Version: 3.0 Branch → unspecified
QA Contact: file.handling → download.manager
This seems to be working with FF5.0
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.