CSAT: Responses to "Was this article easy to understand?" are not appearing on tiki-poll_results.php

VERIFIED FIXED in 0.7

Status

support.mozilla.org
Knowledge Base Software
--
major
VERIFIED FIXED
9 years ago
8 years ago

People

(Reporter: stephend, Assigned: xb95)

Tracking

unspecified
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: sumo_only, URL)

(Reporter)

Description

9 years ago
I've been answering "No" to the "Is this article easy to understand" on http://support-stage.mozilla.org/en-US/kb/Using+Firefox and checking it out via http://support-stage.mozilla.org/tiki-poll_results.php with "All" as a filter, and I only ever see the "Did this article solve" rankings...

Steps to Reproduce:

1. Load http://support-stage.mozilla.org/en-US/kb/Using+Firefox
2. At the bottom, answer "No" to "Was this article easy to understand?"
3. Visit http://support-stage.mozilla.org/tiki-poll_results.php, and either search for "Using Firefox" via the "Find" textfield, or load all of them and CTRL+F your way to the question.

Expected Results:

Immediately after answering "No" to the above question, I should see an entry for that question, along with "No" and the count, in real-time.

Actual Results:

I only ever see counted responses for the "Did this article solve a problem you had with Firefox?"
(Reporter)

Updated

9 years ago
Blocks: 452829

Updated

9 years ago
Depends on: 456772

Updated

9 years ago
Blocks: 456772
No longer depends on: 456772

Comment 1

9 years ago
This should be fixed by running:

update tiki_polls set publishDate='1222300800' where publishDate ='1227312000'; 

Mark, can you run this on the staging database whenever possible so as to
facilitate testing by stephend on Monday? I have downgraded this bug to major
to avoid paging or any such things.

The votes are being recorded, but because the poll publishDate is set to
November, they are just not being displayed on the Poll Results page.

I tried some workaround using the polls admin interface on the site but messed
up the "Using Firefox" poll further instead (that polls admin interface needs
some updating)

Updated

9 years ago
Severity: critical → major
(Assignee)

Comment 2

9 years ago
Query run on staging database.

mysql> update tiki_polls set publishDate='1222300800' where publishDate ='1227312000';
Query OK, 3640 rows affected (0.06 sec)
Rows matched: 3640  Changed: 3640  Warnings: 0
Assignee: nobody → mark
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(Reporter)

Comment 3

9 years ago
While testing this, I filed bug 457492.

Perhaps I caused that bug by going to tiki-poll_results.php instead of the newer one?
OS: Mac OS X → All
Hardware: PC → All

Comment 4

9 years ago
tiki-poll_results.php is supposed to be used. Please do test that. As for the possible cause of bug 457492, I have commented there.
(Reporter)

Updated

9 years ago
Depends on: 457492
(Reporter)

Comment 5

9 years ago
Nelson: if we wontfix bug 457492, will that question be OK in production?  i.e., did we only screw up the staging DB?

Comment 6

9 years ago
we only messed up the staging db
(Reporter)

Comment 7

9 years ago
OK; I haven't seen this with other articles, and so I've tested on rating http://support-stage.mozilla.org/en-US/kb/blah2, and seeing the results successfully up on http://support-stage.mozilla.org/tiki-poll_results.php.

Verified "FIXED".
Status: RESOLVED → VERIFIED

Updated

8 years ago
Whiteboard: sumo_only
You need to log in before you can comment on or make changes to this bug.