Fennec should be distributed through maemo.org Extras instead of its own repository

RESOLVED INCOMPLETE

Status

Fennec Graveyard
General
--
enhancement
RESOLVED INCOMPLETE
9 years ago
6 years ago

People

(Reporter: Ryan Abel, Unassigned)

Tracking

Dependency tree / graph
Bug Flags:
wanted-fennec1.0 +

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US) AppleWebKit/525.18 (KHTML, like Gecko, Safari/525.20) OmniWeb/v622.2.0.104805
Build Identifier: 

Currently Fennec is distributed through its own repository, but this is somewhat less than desirable. Partly because the Maemo community has a bad history for 3rd party repositories, and partly because it complicates things for end users.

Fortunately, maemo.org provides the Extras repository just for distributing community packages. The advantage to using Extras is that you wont have to maintain your own repository, it will be easier for users to install and update Fennec, and you'll have access to a much larger audience of testers (as most users have Extras enabled, as it ships on the device by default). You'll also generate a lot of good will with the community by closing down a superfluous 3rd party repository and moving its contents to Extras. :)

Specifically, Extras-devel is where Fennec should go until it hits a beta state, as it's not yet stable enough for Extras proper. Most of the sorts of people you'd want testing (i.e., those that are likely to file useful bugs and provide useful feedback and patches, etc. ;)) have Extras-devel enabled, anyway.

Reproducible: Always

Updated

9 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 1

9 years ago
We want to have several different update channels... one for nightly builds and one for releases.  Any thoughts on how we might run both of these?  It should be pretty straight forward to do put releases up on maemo.org.
Flags: wanted-fennec1.0+
(Reporter)

Comment 2

9 years ago
(In reply to comment #1)
> We want to have several different update channels... one for nightly builds and
> one for releases.  Any thoughts on how we might run both of these?  It should
> be pretty straight forward to do put releases up on maemo.org.

Nightlies clearly don't belong in Extras-devel, both for the sanity of users (who probably don't want to be notified of updates that often) and for your own sanity (fighting the autobuilder that often sounds like a recipe for a meltdown ;)).

So, I'd put your releases in Extras-devel (for now, until things are more stable--Extras once it gets into a stable beta), and put the nightlies in your own repo.

Updated

9 years ago
Depends on: 456082
Duplicate of this bug: 526796
(Reporter)

Comment 4

8 years ago
So I guess this is WONTFIX, then? What since Fennec's in the Ovi Store now.
There's a nightly catalog, a release catalog and the ovi store. We can close this bug as fixed.

nightly: http://ftp.mozilla.org/pub/mozilla.org/mobile/nightly/
release: http://www.mozilla.com/m
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

8 years ago
(In reply to comment #5)
> There's a nightly catalog, a release catalog and the ovi store. We can close
> this bug as fixed.
> 
> nightly: http://ftp.mozilla.org/pub/mozilla.org/mobile/nightly/
> release: http://www.mozilla.com/m

I'd say not in the least, please see the summary line again. Fennec is /not/ being distributed through Extras, therefor the bug /isn't/ fixed.
> Fortunately, maemo.org provides the Extras repository just for distributing
> community packages. The advantage to using Extras is that you wont have to
> maintain your own repository, it will be easier for users to install and update
> Fennec, and you'll have access to a much larger audience of testers (as most
> users have Extras enabled, as it ships on the device by default). You'll also
> generate a lot of good will with the community by closing down a superfluous
> 3rd party repository and moving its contents to Extras. :)

I tried reading between the lines and determining that the real problem was downloading the build without having to install a 3rd-party repository. I think Firefox's inclusion to the ovi store fixes that behavior, but seeing as how you want it specifically in the extras repository, I'll re-open the bug. Thank you for your due diligence.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 8

8 years ago
(In reply to comment #7)
> I tried reading between the lines and determining that the real problem was
> downloading the build without having to install a 3rd-party repository. I think
> Firefox's inclusion to the ovi store fixes that behavior, but seeing as how you
> want it specifically in the extras repository, I'll re-open the bug. Thank you
> for your due diligence.

There are a couple of issues. First, the Ovi Store doesn't make it easy for people to find sources. Second, the Ovi Store does not show its packages in the built-in package manager.

My other problem is that not uploading it to Extras feels like a cop-out. "Fennec can't get through the autobuilder, but we can't really be bothered to fix it."

Updated

8 years ago
Depends on: 481508

Comment 9

6 years ago
Maemo is tier 3.
Blocks: 701113
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago6 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.