All users were logged out of Bugzilla on October 13th, 2018

[CBX]OPTGROUPs using height, line-height or font-size cause various problems on SELECT and dropdown [INLINE]

RESOLVED FIXED in Future

Status

()

P4
normal
RESOLVED FIXED
19 years ago
16 years ago

People

(Reporter: make, Assigned: rods)

Tracking

({css1, testcase})

Trunk
Future
css1, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CSS1-5.4.8][CSS1-5.5.24][CSS1-5.2.6])

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.73 [en] (WinNT; U)
BuildID:    2000071720

If a SELECT has OPTGROUPs which use a different (larger) height, line-height or 
font-size, the SELECT seems to "inherit" the larger values from the OPTGROUP. 
Two additional problems are demonstrated in the testcase.

Reproducible: Always
Steps to Reproduce:
1. Load the testcase


Actual Results: 
2a) All 3 SELECTs have their height enlarged. 
2b) The dropdown of the first SELECT shows that a large font-size of OPTGROUPS 
does not lead to an adjusted line-height for them (in the dropdown).
2c) The dropdown of the third SELECT shows that a specified height leads to a 
very strange dropdown (don't know how to describe it better) which may be 
another error.

Expected Results:  (My _opinions_)
a) The SELECT should only be enlarged for content which _may_ be displayed in 
it. OPTGROUPs can not be selected and will never be displayed in the SELECT 
(selection field). I think, the SELECT therefore should keep the small size, 
that has been specified for it.
b) If an OPTGROUP uses a large font size, either it's line-height (_in the 
dropdown_) should be enlarged _or_ it should be clipped.
c) The third dropdown is unreadable. I'm not sure, if height on dropdown should 
have this effect. I would think it either should be ignored or be accepted _and_ 
set a clipping box for it's contents.
(Reporter)

Updated

19 years ago
Keywords: css1, testcase
(Reporter)

Comment 1

19 years ago
Created attachment 11519 [details]
testcase
(Assignee)

Comment 2

19 years ago
When using style to manipulate the size elements, they should behavior how 
layout would treat anything else. The fact that they are inside a select should 
really have no bearing on their layout.

So. it seems to me that testcase #1 and #2 are doing the right thing. If you set 
the line height large and the font small or vise-versa lthe layout should be 
behave as it does in the test. If it doesn't have the correct visual effect then 
don't do that. The question I do have and will look into is whether the any 
clipping should be done (like when the font makes the text larger than the line 
height).

The #3 testcase where the height of the optgroup is set to 41px seems to be 
wrong. Layout is not calculating something right here. These are all layout 
issue and really don't have much to do with the select. 

I am futuring this for now because it is not critical for shipping.
Status: NEW → ASSIGNED
Target Milestone: --- → Future
QA Contact: ckritzer → py8ieh=bugzilla
Summary: OPTGROUPs using height, line-height or font-size cause various problems on SELECT and dropdown → OPTGROUPs using height, line-height or font-size cause various problems on SELECT and dropdown [INLINE]
(Assignee)

Updated

18 years ago
Summary: OPTGROUPs using height, line-height or font-size cause various problems on SELECT and dropdown [INLINE] → [CBX]OPTGROUPs using height, line-height or font-size cause various problems on SELECT and dropdown [INLINE]
(Assignee)

Updated

18 years ago
Priority: P3 → P2
Target Milestone: Future → ---
Setting milestone to future.
Target Milestone: --- → Future

Comment 4

18 years ago
The only problem I'm seeing in build 2001060409 Win98 is that a lot of
overlapping is taking place. For obvious reasons nothing should be overlapping
in here (unless maybe there is a negative value for something that pulls the
surroundings in).

The increased width of test #1 makes sense, because the listbox should match the
width of its menu, but the large OPTGROUPS shouldn't overlap the OPTION elements
in the list. Right now the bottom of each OPTGROUP covers the OPTION below it
and the opposite for the top. As a result "45 Minuten" is difficult to select,
among others.

I can't find anything wrong with test #2. It appears to be rendering as expected.

Test #3 is totally wrong, though. I would expect it to behave similar to test
#2. This is a more serious problem.
(Assignee)

Updated

17 years ago
Priority: P2 → P4
Whiteboard: [CSS1-5.4.8][CSS1-5.5.24][CSS1-5.2.6]

Comment 5

17 years ago
Confirmed using FizzillaCFM/2002070913. Setting All/All.
OS: Windows NT → All
Hardware: PC → All
Depends on: 82265
Fixed by checkin for bug 82265.  Test #3 still has overlapping and that
overlapping is correct.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.