Closed Bug 457470 Opened 12 years ago Closed 11 years ago

Update public suffix (effective TLD) list (3)

Categories

(Core :: Networking, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla1.9.1b2

People

(Reporter: david+mozilla, Assigned: gerv)

References

Details

(Keywords: fixed1.9.0.4)

Attachments

(1 file)

User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)
Build Identifier: 

The public suffix list is a list of domain endings (e.g. .at, .co.uk, ...) that is used for managing cookie permissions and so on, so it is a good idea to keep it up to date. While using the list for some research, I discovered some out-of-date entries (of course I am not sure if the list is complete).

Reproducible: Didn't try
.my does allow second-level registrations as well

Update .gh: Rregistrations at 2nd level were possible, some old domains still exist.

Add entry for .se (shouldn't this one be fixed already?); see bug #455587

Update .sy (old information was outdated)

Remove goa.pk; not listed on http://pk5.pknic.net.pk/pk5/pgStructure.PK

Add link to .kz rules page

Remove myname.jo:  Myname.jo was just used as an example for direct egistrations at the second level and is not a public suffix.
Confirming, assigning to Gerv on the theory that he'll have to approve this and check it in anyway.

I think there's a bug on .my already, but it could depend on this one.
Assignee: nobody → gerv
Status: UNCONFIRMED → NEW
Ever confirmed: true
.my is bug 456004.

Gerv
Blocks: 456004
Comment on attachment 340755 [details] [diff] [review]
Patch for public suffix list
[Checkin: Comment 7]

r=gerv.

Gerv
Attachment #340755 - Flags: review+
.my is blocking19.0.4+, so let's try and get a move on with this whole patch and get it all on both trunk and branch.

Gerv
Tagging this as checkin-needed. Please check this into the trunk as soon as possible, because there are some sites for which cookies are broken (see the bug blocked by this bug) without the patch.
I'll file another bug for inclusion into the 1.9.0 branch if no problems arise within a week.
Keywords: checkin-needed
Version: unspecified → Trunk
Comment on attachment 340755 [details] [diff] [review]
Patch for public suffix list
[Checkin: Comment 7]

http://hg.mozilla.org/mozilla-central/rev/5739a6b48812
Attachment #340755 - Attachment description: Patch for public suffix list → Patch for public suffix list [Checkin: Comment 7]
Status: NEW → RESOLVED
Closed: 11 years ago
Flags: in-testsuite-
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.1b2
Do we need this for 1.9.0 as well?
Flags: blocking1.9.0.5?
Dan: yes, please, if at all possible. I suspect David was unaware of the schedule and so didn't file the bug he mentions in comment #6 in time.

Is it now too late to take it for 1.9.0.4? I believe there's another 12 hours until code freeze...

Gerv
an actual approval request flag, or a ping in IRC would be more effective when there's only hours left.

The starting place for schedule questions is http://wiki.mozilla.org/Releases -- bookmark that link.
Comment on attachment 340755 [details] [diff] [review]
Patch for public suffix list
[Checkin: Comment 7]

Approved for 1.9.0.4, a=dveditz
Attachment #340755 - Flags: approval1.9.0.4+
Checking in netwerk/dns/src/effective_tld_names.dat;
/cvsroot/mozilla/netwerk/dns/src/effective_tld_names.dat,v  <-- 
effective_tld_names.dat
new revision: 1.8; previous revision: 1.7
done

Gerv
Flags: blocking1.9.0.5?
You need to log in before you can comment on or make changes to this bug.