Closed Bug 457493 Opened 15 years ago Closed 14 years ago

Page Scrolling Broken with Fixed Div

Categories

(Firefox :: General, defect)

3.0 Branch
x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 162369

People

(Reporter: mozilla, Unassigned)

References

()

Details

Attachments

(1 file)

FF 3.0.2

If a page has a fixed-position DIV at the top or bottom of the viewport, scrolling one page at a time (PgDn, SPACE, etc.) is broken. The page scrolls the length of the entire viewport, not the length of the viewport - height of fixed DIV.

Another reason frames are better than fixed DIVs.
Pg up and down appears to works fine on the URL; tested on Windows XP.
Please make sure you didn't accidentally press f7, it will toggle caret browsing.
Screens 1 and 2 are before and after PgDn. Screen three shows the area that is skipped in yellow. Caret browsing is not enabled.
The height of the skipped part is equal to the height of the image used to create the shadow effect on the fixed DIV.
Then, you can make a testcase which makes the problem clear?
http://developer.mozilla.org/en/Reducing_testcases
Keywords: testcase-wanted
Dupe of bug 162369 as per (for example) bug 206677.
Status: NEW → RESOLVED
Closed: 14 years ago
Keywords: testcase-wanted
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.