bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

"error getting url widget service" for each page that loads

RESOLVED FIXED

Status

()

Core
XUL
P3
normal
RESOLVED FIXED
18 years ago
18 years ago

People

(Reporter: R.K.Aa., Assigned: Bill Law)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Linux build ID 2000-071720
This is not quite new - seen it for the past.. 3 days or so.

Whenever a page loads, this error message appears one or more times in console:

Error getting url widget service: TypeError: Components.classes[progid] has no
properties


Uncertain about component

Comment 1

18 years ago
This is the urlwidget, which is not implemented on linux (so we should
probably just fail silently).   --> law
Assignee: trudelle → law
(Reporter)

Comment 2

18 years ago
what am i missing.. i thought perhaps the url-widget was that little arrow
pointing down, that drops down a list of the current sessions manually entered
sites?

Comment 3

18 years ago
I just voted for this bug since it is rather important for testing with the
browser buster. Until a few days ago under Linux, the buster reported the URL of
each page loaded. Thus, when mozilla crashed, I could go back and examine the
offending page. At the very least, I was able to put the URL in the talkback
report.
(Assignee)

Comment 4

18 years ago
The "url widget" is a Windows-only thing.  I'll tweak the JS code so it doesn't
complain to the console.
Status: NEW → ASSIGNED
(Reporter)

Comment 5

18 years ago
ahh ok. I thought it might have to do with the wrong look of the URL-fields
menu-button. (skin missing or something so the down-arrow is black on plain
white, only a turqoise line beside it is left of the button-look it used to have)
(Reporter)

Comment 6

18 years ago
it simply not displaying in console might not be the "final solution":
Please load http://www.dir.bg to see a worst case:
I get several thousand of those error lines displayed in console there, and when
the page has finally loaded (after a very long time!) - all cyrillic text
display as sqares. Almost like the error displays once for each character on page.

That url had a bug but marked WFM, bug 47514 (the reported blinking couldn't be
reproduced). But something is severely wrong on that page.

(For comparision: NC 4.72 displays it in "no time" - and with correct characters.)

Tested with a P3/500 on linux 2000080409.

Comment 7

18 years ago
Open a separate new bug for what you note above. There is something wrong 
with that page (I think it's getting an excessive number of load notifications
for some reason). 

However, this bug really is just about an error message; it should be quieted
on linux/mac, but it's not an indication of some deeper problem.

Comment 8

18 years ago
pav commented these lines out; checked-in this afternoon. Marking Fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.