If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

graphs of trace-malloc leak test ignore units

RESOLVED DUPLICATE of bug 433710

Status

Release Engineering
General
RESOLVED DUPLICATE of bug 433710
9 years ago
4 years ago

People

(Reporter: dbaron, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

http://graphs.mozilla.org/graph.html#show=1473418,1473670,1474269 is a graph of the results of the trace-malloc leak tests running on mozilla-central.  This graph doesn't make a whole lot of sense, since it's showing numbers in the range 1-1000.

The Windows leak number is around 190KB, so it shows up as about 190.  The Mac leak number is around 2.5MB, so it shows up as around 2.5.  The Linux leak number hovers right around 1MB, so it jumps back and forth between 1 and 1000 on the graph.

The graph should instead be graphing the number of *bytes* leaked.

Steps to reproduce: load http://graphs.mozilla.org/graph.html#show=1473418,1473670,1474269

Actual results: Mac and Linux numbers almost 0 relative to Windows number, except Linux occasionally spiking to higher.

Expected results:  Mac number about 2.5 times Linux number, which in turn is about 4 times the Windows number.
We caught this in bug 433710, where sending to the graph server was originally implemented. There's a patch that needs deploying. Dupe this over ?

Moving over to RelEng since these results come of "leak test" boxes rather than Talos.
Component: Release Engineering: Talos → Release Engineering
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 433710
(Assignee)

Updated

4 years ago
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.