version 2.0.0.17 no longer blocks images in junk mail

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
10 years ago
9 years ago

People

(Reporter: dan, Unassigned)

Tracking

({testcase-wanted})

1.8 Branch
x86
Windows Vista
testcase-wanted

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2010-02-19])

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; SLCC1; .NET CLR 2.0.50727; Media Center PC 5.0; .NET CLR 3.0.04506; .NET CLR 1.1.4322)
Build Identifier: 2.0.0.17 (20080914)

since upgrading to .17, I am now being shown images in email from unauthorized parties, allowing spammorz to know they were successful in reaching a real email address.

I liked that feature (blocking images until you specifically authorized them). If it is in preferences somewhere, I cannot find it.


Reproducible: Always

Steps to Reproduce:
1. receive a vicod1n/V1 gra spam with a image url in it
2. hope the image is blocked, since otherwise the code in the url tells them your email address is one which is actually read
3. cry
Actual Results:  
image is no longer blocked, even though not approved for that source email address and the message is also marked as junk.

Expected Results:  
blocked all images in the junk mail.  offered to allow images from non-junk, trusted, domains?

Again, this just started happening after the .17 update, which otherwise went without incident.

---

I am, however, one of those people with a creative labs webcam which must be manually shut down to enable the TB update to work.  The TB error message in that case is not completely helpful, but I accept it is really more of a Creative Labs issue.  Though I guess TB might be expected to just say "could not be completed, you must reboot to finish installation" in the case that a DLL was not overwritable (which is what I assume the problem is), though exactly which DLL you would be overwriting that was common to creative labs is a bit disturbing as it might imply you are modifying my windows DLLs, which I would prefer you didn't do, of course.)

blah blah blah.
Are you sure the images remote, and not inline? If so, can you attach a sample? (Save as .eml)
Summary: version .17 no longer blocks images in junk mail → version 2.0.0.17 no longer blocks images in junk mail
Version: unspecified → 2.0

Comment 2

10 years ago
I was going to file this as a new bug but here it is. Same symptoms, timing and version history. Worked fine before. Ignores the setting to allow remote images in the address book. Here is the source of such an email:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<head>
  <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
 </head>
<html>
<body bgcolor="#FFFFFF" leftmargin="0" topmargin="0" marginwidth="0" marginheight="0">
<p align="center"><FONT SIZE="1" COLOR="#000000" FACE="ARIAL">If you are unable to see the message below, <A href="http://uydohb.gyzirme.cn/">click here to view</A>.<br>

</FONT><font face="ARIAL" color="#808080" size="2"><br>
</font></CENTER>
</p>
<div align="center">
  <table border="0" width="600" cellspacing="0" cellpadding="0">
    <tr>
      <td>
      <p align="center"><a href="http://afu.gyzirme.cn/"><img border="0" src="http://aih.gyzirme.cn/7.jpg"></a></td>
    </tr>
  </table>

</div>
<table width="555" border="0" align="center" cellpadding="10" cellspacing="0">
  <tr>
    <td align="center" class="gray">
      <p> <font size="-1" color="#999999" face="Arial, Helvetica, sans-serif">You have received this message because you opted in to receives ClickCulture pecial <br>
        offers via email. Login to your member account to</font> <font size="-2" face="Arial, Helvetica, sans-serif">
  <a href="http://weais.gyzirme.cn/" >
  <font color="#999999" size="-1">edit your email subscription</font></a>
  <font color="#999999" size="-1">.</font><font color="#999999"><br>
        <font size="-1">Click here to</font>
  </font></font> <font size="-2" face="Arial, Helvetica, sans-serif">
  <a href="http://aoqtf.gyzirme.cn/optout.aspx?user=altaphon@altaphon.com" >
  <font color="#999999" size="-1">unsubscribe</font></a><font color="#999999" size="-1">.</font><br>
        <br>
        <font color="#999999" size="-1">PLEASE DO NOT REPLY - This is being sent
        from an unattended mailbox. <br>
      <p><font color="#999999" size="-1" face="Arial, Helvetica, sans-serif">Copyright &copy; 2008 ClickCulture, Inc. All rights reserved.<br>
        3739-210 NATIONAL DR, Raleigh, NC 27612</font></p>
    </td>
  </tr>

</table>
</body>
</html>
Dan could you attach the email in .eml format to the bug please ? Do you also have the issue with Thunderbird 3.0b1 ?
Component: General → Filters
Product: Thunderbird → MailNews Core
QA Contact: general → filters
Version: 2.0 → 1.8 Branch

Comment 4

10 years ago
dlj. Dan Can you reproduce with beta 2 (or 3)?
  http://www.mozillamessaging.com/en-US/thunderbird/early_releases/

If you can, please attach testcase
Keywords: testcase-wanted
Dan could answer to comment #3 and comment #4, please?
Whiteboard: [closeme 2010-02-19]
RESOLVED INCOMPLETE due to lack of response to last question. If you feel this change was made in error, please respond with your reasons why.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.