Last Comment Bug 457665 - Restore in Organize Bookmarks doesn't show recent files in German version of Firefox 3.0.3
: Restore in Organize Bookmarks doesn't show recent files in German version of ...
Status: RESOLVED DUPLICATE of bug 445704
:
Product: Firefox
Classification: Client Software
Component: Bookmarks & History (show other bugs)
: unspecified
: x86 Linux
: -- normal with 1 vote (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-29 05:56 PDT by Ralph Plawetzki
Modified: 2008-12-20 01:47 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Ralph Plawetzki 2008-09-29 05:56:41 PDT
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008071618 Iceweasel/3.0.1 (Debian-3.0.1-1)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; de; rv:1.9.0.3) Gecko/2008092416 Firefox/3.0.3

Dear Developers,

there is an inconsistency in the Import and Backup >  Restore menu of the Organize Bookmarks tool.

When I use the English version of Firefox 3.0.3 and chose Bookmarks > Organize Bookmarks from the menu and then Import and Backup >  Restore I see „Choose file...“ and above that all files in /home/rallo/.mozilla/firefox/1lshi8co.default/bookmarkbackups that are named bookmarks-<specific_date>.json.

When I install the German version of Firefox 3.0.3 the files in /home/rallo/.mozilla/firefox/1lshi8co.default/bookmarkbackups are named Lesezeichen-<specific_date>.json. When I now chose Import and Backup >  Restore I only see „Choose file...“ with no recommendations of formerly saved bookmark files above.

I would like to see these files in the German Firefox too, because /home/rallo/.mozilla/firefox/1lshi8co.default/bookmarkbackups is a litte hard to remember ;)

Please take a look at that.

Many thanx,

Regards,
Ralph

Reproducible: Always

Steps to Reproduce:
1. add a bookmark
2. chose Bookmarks > Organize Bookmarks from the menu and then Import and Backup >  Restore
3.
Actual Results:  
see above

Expected Results:  
see above
Comment 1 Karel Kolman 2008-11-16 00:50:28 PST
I confirm this behavior (using the Czech version), the bookmarkbackups folder contains "bookmarks-2008-05-17.json" as the last file named in the locale independent manner. Bookmark manager offers to restore from these locale independent files, newer backups (like "zalozky-2008-11-16.json") are not offered.

BTW I think the bug component settings should be "Bookmarks & History" insetad of "Menus".
Comment 2 Gunther Walther 2008-12-19 08:58:00 PST
I confirm a similar bug on the German Mac OS version and have additonal information.
Looking at the bookmark backup folder it looks like there was a filename change and this is may be causing some problems:

gunther-walthers-imac:3qgbsw9b.default gunther$ ls bookmarkbackups/
Lesezeichen-2008-12-15.json  Lesezeichen-2008-12-17.json  Lesezeichen-2008-12-19.json  bookmarks-2008-08-14.html    bookmarks-2008-08-28.html    
Lesezeichen-2008-12-16.json  Lesezeichen-2008-12-18.json  bookmarks-2008-08-12.html    bookmarks-2008-08-19.html    

When my bookmarks started to behave odd I followed the procedure of recovering booksmarks: http://kb.mozillazine.org/Locked_or_damaged_places.sqlite but what I got were old bookmarks. I suspect that the recovery procedure goes into the backup folder and looks for "bookmarks" files and not "Lesezeichen-" files. While I don't know whether this is 100% the cause of above mentioned problems it could well be the root cause for a whole family of problems.

The good news for everyone who found this post is that there may be a up-to-date jsom file if you just look for the right file and rename it. Should work although I was still able to export html and recovered from bookmarks.html in the profile folder (have I mentioned that the problem shows up in more than one place 8-( )

Imho the benefit of having language dependent filenames are always never worth the trouble but people keep trying...
Comment 3 Marco Bonardo [::mak] 2008-12-20 01:47:31 PST

*** This bug has been marked as a duplicate of bug 445704 ***

Note You need to log in before you can comment on or make changes to this bug.