Last Comment Bug 457765 - Anchor-element wrapped outside <li>-element gets duplicated inside it
: Anchor-element wrapped outside <li>-element gets duplicated inside it
Status: RESOLVED DUPLICATE of bug 324875
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: unspecified
: x86 Windows XP
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-29 14:57 PDT by jrundruud
Modified: 2009-05-03 04:14 PDT (History)
0 users
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description jrundruud 2008-09-29 14:57:42 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3

When creating an anchor-element which wraps an list item, firefox closes the anchor tag before the li-element starts. It also creates an additional anchor-element inside the list item.
Example:
<a href="#"><li>Lorem ipsum</li></a>
becomes 
<a href="#"></a><li><a href="#">Lorem ipsum</a></li>

Reproducible: Always

Steps to Reproduce:
1.Create an HTML-document which contains an anchor element wrapping a list item.
2.Open it in firefox, select the text and click "View selection source"
Comment 1 Daniel.S 2009-05-03 04:14:20 PDT
Thanks for reporting.

*** This bug has been marked as a duplicate of bug 324875 ***

Note You need to log in before you can comment on or make changes to this bug.