bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Plugin disabling in Addons Manager does not stick

VERIFIED FIXED

Status

Firefox for Android Graveyard
General
VERIFIED FIXED
10 years ago
10 years ago

People

(Reporter: [PTO until July 27], Assigned: db48x)

Tracking

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

10 years ago
If a user goes into the Addons Manager in Fennec and disables a plugin (say, Flash) and then restarts Fennec, the plugin is enabled on restart. The setting does not stick.

I have confirmed with about:plugins that on the initial disable, the plugin is disabled. The same page shows that it is back once Fennec is restarted.

This was found in Stuart's build 20080929152532.

Steps to Reproduce
1. Start Fennec
2. Select the "Gear" icon in the right hand pane to open the Addons Manager
3. Select the "Plugins" tab there
4. Select Flash and then the "Disable" button
5. Go to about:plugins

Flash is disabled.

6. Exit Fennec and restart it.
6. Go to about:plugins

Results: Flash has been enabled again.
(Assignee)

Comment 1

10 years ago
Hrm. I can't reproduce this. This setting is backed by a pref, and on startup that pref is read and the plugins are either enabled or disabled. The pref has the right value on startup in both cases, and the proper code is executed on startup in both cases. I'll investigate further.
(Assignee)

Comment 2

10 years ago
Heh, sometimes it helps to actually read the steps to reproduce. Yes, I knew that the addons manager and the pref would conflict, I just hadn't gotten around to filing a bug. My apologies. In the mean time, just disable them with the pref instead.
(Assignee)

Comment 3

10 years ago
Created attachment 341093 [details] [diff] [review]
457781-1.diff
Attachment #341093 - Flags: review?(mark.finkle)
Attachment #341093 - Flags: review?(abillings)
Attachment #341093 - Flags: review?(mark.finkle) → review+
(Assignee)

Comment 4

10 years ago
I need someone with plugins that work on their system to double-check this, which is why I requested a review from Al.
(Assignee)

Comment 5

10 years ago
Created attachment 341097 [details] [diff] [review]
457781-2.diff

On second thought, we do want to unilaterally disable all plugins the _first_ time Fennec starts up, at least until we fix the crashes.
Attachment #341093 - Attachment is obsolete: true
Attachment #341097 - Flags: review?(mark.finkle)
Attachment #341093 - Flags: review?(abillings)
Comment on attachment 341097 [details] [diff] [review]
457781-2.diff

use a "temporary.disablePlugins" pref?
Attachment #341097 - Flags: review?(mark.finkle) → review+
(Assignee)

Comment 7

10 years ago
pushed
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
(Reporter)

Comment 8

10 years ago
Did we wire up the UI or did we just disable everything for now? :-)
(In reply to comment #8)
> Did we wire up the UI or did we just disable everything for now? :-)

We should be disabling plugins on first run in a profile. Both UI's (Add-ons Manager and the Preferences) should be able to toggle the plugin state.

However, the UI's don't use the same mechanism so they could become out of sync

We should consider whether we want to keep plugin state management in 2 places or just remove one or the other.
(Reporter)

Comment 10

10 years ago
This bug is resolved as "fixed" so I was trying to ascertain, before I get a build, what was "fixed" for this resolution.
(Assignee)

Comment 11

10 years ago
to be more specific, the prefs ui disables all plugins in one go, while the addons ui lets you disable them one at a time. You now can set your plugins to disabled in the prefs and then go enable one plugin and everything will work like you expect. Still, I suspect the pref will end up going, since it could be a little confusing.
(Reporter)

Comment 12

10 years ago
This isn't fixed. I just tried in the build that John O'Duinn just made (20080930) and the settings still don't stick. If I disable Flash through the Add-ons UI, it never stays disable after restart.
(Reporter)

Comment 13

10 years ago
Verified with a build from today.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.