ALL Message Filters disappear from the Message Filters window but keep working, eventually reappear as good as new, and the process repeats.

RESOLVED WORKSFORME

Status

defect
--
minor
RESOLVED WORKSFORME
11 years ago
9 years ago

People

(Reporter: gtrosper, Unassigned)

Tracking

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3
Build Identifier: version 2.0.0.17 (20080914)

When I choose Tools, Message Filters, I never know if they'll all be there or none of them will be there.  The likelihood of their disappearing seems to be somewhat higher if the currently selected folder is not Inbox, but that's only a tendency.

I cannot tell for certain whether I have the same or different problem than the problem(s) discussed at http://forums.mozillazine.org/viewtopic.php?f=31&t=196958 , but the discussants there are not satisfied.  Moreover, there is at least one claim that the update from 12 to 14 didn't help.

Reproducible: Sometimes

Steps to Reproduce:
1. Choose Tools, Message Filters.
2. Same again, usually in a different session--but see "Actual Results".
3. Same again.
Actual Results:  
See Summary and Details above.  Particularly note that, as stated in the Summary, the filters never stop working; they're just invisible and therefore not editable.  And just now, the Filters came back without my having even closed Thunderbird down.

I once tried adding a new filter when the old ones weren't displayed.  I *think* it was present among the old when they all appeared.  In any case, I haven't tried that again, and don't intend to; the randomness of disappearance feels too fragile for me to want to chance it.

Expected Results:  
Always displayed all extant message filters.

I'm not sure this actually belongs in "Mail Window Front End," because I'm not sure that filters are part of the front end.  But it seems more likely to be right than "General," and there are no other plausible candidates for category.
Have you checked what the "Filters For:" drop down box at the top of the dialog says?

The default will be relative to whatever folder you've got selected, e.g. click on a News & Blogs folder and you'll get the News & Blogs filters shown; click on an email account and you'll get the email account filters shown.

So if you've not got the right account shown, just select the correct one through the "Filters For:" drop down.
Reporter

Comment 2

11 years ago
The "Filters For:" drop-down box currently shows my email address, and the display currently shows all filters.  The other choices are "Local Folders" and the "news" folder; when I select either of those, the display blanks.

The next time I find the filters missing, I shall certainly read that box.  I never touch it, but IF it's changing itself randomly, changing it back will be a workaround I can cope with!

Thank you, Mr. Banner!

(In reply to comment #1)
Reporter

Comment 3

11 years ago
That may well be the idiotic problem!  I just reopened Thunderbird, and with Inbox selected, chose Tools, Message Filters.  This time "Local Folders" came up in "Filters For:".  Changing to my address displayed the filters.

It seems to me that the box in question should be more stable and predictable, but that is a minor bug, at worst.  I have therefore changed the "Importance" setting in this report.
 
(In reply to my own comment #2)
Severity: major → minor
Version: unspecified → 2.0
Do you use global inbox? This could be why it is slightly less predictable.
Reporter

Comment 5

11 years ago
Sorry, I don't understand the question, sir.

(In reply to comment #4)
> Do you use global inbox? This could be why it is slightly less predictable.
Two occasion is known for save failure of msgFilterRules.dat.
  - Bug 362539 : garbages of tmprules-NNNN.dat in temporary directory
  - Bug 450424 : garbage of tmprules.dat in mail directory.
Check files in temporary directory and all account's mail directory first.
  If MS Win, do next at Command Prompt.
     C:
     MD C:\WORK
     CD <dir>
     DIR tmp*.* /S > C:\WORK\DIRLIST.TXT
     notepad.exe C:\WORK\DIRLIST.TXT
  where <dir> is %TEMP%, or directory set in "Local Directory:" field of each
  account's Account Settings/Server Settings.
Reporter

Comment 7

9 years ago
(In reply to comment #6)
The problem is NOT, so far as I can see, a "save failure". As noted, the rules are all there, and all work. The ONLY problem is the Message Filters window automatically coming up with Filters for Local Folders chosen when they're all saved under my email address instead.

I'm mildly curious why I got an email notice about this today, when the last activity was last July--but not curious enough to keep this going uselessly! Since apparently no one else finds this anomaly a problem, and I long ago learned the work around, I'm marking this thread Resolved and will forget about it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.