Password prompt doesn't prompt after creating new CalDAV calendar.

RESOLVED WORKSFORME

Status

Calendar
Provider: CalDAV
--
major
RESOLVED WORKSFORME
9 years ago
9 years ago

People

(Reporter: Nikita, Unassigned)

Tracking

Lightning 0.9
x86
Linux

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; ru; rv:1.8.1.3) Gecko/20060601 Firefox/2.0.0.3 (Ubuntu-edgy)
Build Identifier: Thunderbird: version 2.0.0.17 (20080914). Lightning: 0.9

After creating new CalDav calendar and restarting thunderbird the password prompt doesn't prompt! And the following messages goes to console:

<p>test</p>Warning: There has been an error reading data for calendar: Calendar.  However, this error is believed to be minor, so the program will attempt to continue. Error code: DAV_NOT_DAV. Description: The resource at http://imap.jet.msk.su:8100/CalDAV/~voitov/Calendar is either not a DAV collection or not available
Warning: There has been an error reading data for calendar: Calendar.  However, this error is believed to be minor, so the program will attempt to continue. Error code: READ_FAILED. Description: 
<p>test</p>Warning: There has been an error reading data for calendar: Calendar.  However, this error is believed to be minor, so the program will attempt to continue.

If i do the same things on the same windows versions of thunderbird and lightning everything is OK: The thunderbird ask me for password to Caldav calendar and opens it.

I think this is Linux problem only.

Reproducible: Always

Steps to Reproduce:
1. Install last relese of thunderbird
2. Install last release of ligtning addons
3. Create new CalDav calendar
4. Restart thunderbird

Actual Results:  
The created calendar is unavailable because no password was entered after restart.

Expected Results:  
Open the created calendar.
(Reporter)

Updated

9 years ago
Version: unspecified → Lightning 0.9
Moving to 'Provider: CalDAV' component. 'Error code: DAV_NOT_DAV.' looks suspicious.
Component: Lightning Only → Provider: CalDAV
QA Contact: lightning → caldav-provider

Comment 2

9 years ago
I try to reproduce this issue with lightning build 20081212 and it is not possible to reproduce this issue.

Nikita, is this issue still valid?

I get this errormessage: 

Warning: There has been an error reading data for calendar: testuser7 bedework.  However, this error is believed to be minor, so the program will attempt to continue. Error code: DAV_NOT_DAV. Description: The resource at http://localhost:8080/ucaldav/user/testuser7/calendar is either not a DAV collection or not available

only when the calendar url is wrong. Maybe that is the root cause of your issue.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

9 years ago
Thank's to all! It seem's to be resolved in 2008091719. 

But i have another question: Will be support for free/busy information in the feuture lightning's releases?
Resolution: WORKSFORME → FIXED
Resolving as WORKSFORME (we only mark bugs as FIXED if there is a specific patch associated).
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.