Searches on preview are failing

VERIFIED FIXED

Status

addons.mozilla.org Graveyard
Public Pages
--
major
VERIFIED FIXED
9 years ago
2 years ago

People

(Reporter: stephend, Unassigned)

Tracking

({regression})

Details

(URL)

(Reporter)

Description

9 years ago
Searches for "AdBlock" on https://preview.addons.mozilla.org/en-US/firefox/search?q=adblock&cat=all aren't finding "AdBlock" or "AdBlock Plus" -- both of which should exist.

For that matter, it doesn't appear that searches are returning any results at all...
(Reporter)

Comment 1

9 years ago
xb95: could you take a gander?

Comment 2

9 years ago
mysql> select id, locale, status, name, summary from text_search_summary;
Empty set (0.00 sec)

I'm not sure how this table gets populated, but it's totally empty right now.  I.e., there's no data to search on.
Like so many other things on AMO, it's a "cronjobbed" maintenance task: $AMO/bin/update-search-views.php -- if that's not run, either the actual data and the search view diverge, or the search view is never even published in the first place.

Do you want to copy that cron job from production, where (I hope) it is scheduled to run periodically?
(In reply to comment #3)
> Do you want to copy that cron job from production, where (I hope) it is
> scheduled to run periodically?

|php -f update-search-views.php| is run on the 12,32,52 minutes of every hour on both production and staging AMO instances.
This appears to be fixed - it's not clear if Reed fixed it or if he's saying the cron jobs were already there.

I'm resolving the bug though because even if the jobs were already there I don't think it's something webdev can debug.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

9 years ago
This has been working fine for a while; verified.
Status: RESOLVED → VERIFIED
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.