Status

()

Firefox
General
--
major
VERIFIED INVALID
10 years ago
10 years ago

People

(Reporter: Marcin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.3) Gecko/2008092510 Ubuntu/8.04 (hardy) Firefox/3.0.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.3) Gecko/2008092510 Ubuntu/8.04 (hardy) Firefox/3.0.3

when you use <javascript type="text/javascript" src="file.js" />
page is not displaying at all!

you have to use <script ...> </script> not in one tag which ends with <... />

Reproducible: Always

Steps to Reproduce:
1.put the following tag into <head> element <javascript type="text/javascript" src="file.js" />
2.
3.
Actual Results:  
page is not displaying

Comment 1

10 years ago
Umm, yeah. That's because the javascript tag doesn't exist. The issue with closing tags this way is because that's how HTML works - closing a tag by using /> is not proper HTML, it is XHTML.

Marking this bug INVALID, as it's not a bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Component: Disability Access → General
QA Contact: disability.access → general
Resolution: --- → INVALID
(Reporter)

Comment 2

10 years ago
OK so try this with XHTML page. It doesn't work too. It is a bug because page is not displaying at all ! tell me which browser doesn't display the page when the HTML tag is incorrect ?!

Cheers,
M.
which content type your server sends for your xhtml page ?

Comment 4

10 years ago
What web page is this problem on? You can also create a test case, http://developer.mozilla.org/en/Reducing_testcases.
(Reporter)

Comment 5

10 years ago
Hello Guys,

I believe that Gijs Kruitbosch is right. This isn't a bug really, because I wanted to use xhtml tag structure (inline closing <script.../>) in the page with HTML structure. I agree that this isn't keeping the specification, and it isn't a valid tag on HTML pages. However it works on Firefox-2.x.

Thanks you can close this issue.

Comment 6

10 years ago
v.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.