Long filenames in FTP listings are truncated.

RESOLVED DUPLICATE of bug 248667

Status

mozilla.org
FTP: Mirrors
P3
enhancement
RESOLVED DUPLICATE of bug 248667
18 years ago
13 years ago

People

(Reporter: Si Ly, Assigned: Scott Kveton)

Tracking

Details

(URL)

(Reporter)

Description

18 years ago
The directory listing truncates long filenames.  Since the names of files
are often very similar, it is impossible to tell them apart by looking
at the web page.

I suggest configuring Apache to automagically generate wider columns when it
encounters long filenames.  This can be done in httpd.conf as follows:
  IndexOptions FancyIndexing NameWidth=*

Comment 1

18 years ago
Done.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 2

18 years ago
Thanks Si, that rocks. I didn't realize that option existed.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 3

16 years ago
It's happening again, but not all the time.  Maybe some servers are configured
properly, and some aren't?
Status: VERIFIED → REOPENED
Resolution: FIXED → ---

Comment 4

16 years ago
Dawn, please contact Bill.
Assignee: rko → endico
Status: REOPENED → NEW
(Reporter)

Comment 5

16 years ago
What's the update on this? The fix is easy.
We'd need to get this done by all the ftp.mozilla.org mirrors...

Gerv
Assignee: endico → kveton
Component: Server Operations → FTP: Mirrors
QA Contact: endico → myk

Comment 7

14 years ago
Pls. change the description to be more precise, e.g. "Long filenames in FTP
server are truncated."

Updated

14 years ago
Summary: Long filenames are truncated. → Long filenames in FTP listings are truncated.
(Assignee)

Comment 8

13 years ago
We are no longer depending on FTP for end-users.  We use Bouncer and only use
HTTP URL's.
Status: NEW → RESOLVED
Last Resolved: 18 years ago13 years ago
Resolution: --- → FIXED
We don't use bouncer for nightlies, and this is actually talking about the HTTP
directory listings on said servers, not FTP.  This needs to be fixed on anything
that's in the primary round-robin, since that's where people go to get nightlies.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
actually, this appears to have been dealt with on another bug anyway.

*** This bug has been marked as a duplicate of 248667 ***
Status: REOPENED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.