[IMAP] Crash while running in background [@ nsMsgImapLineDownloadCache::nsMsgImapLineDownloadCache]

RESOLVED WORKSFORME

Status

MailNews Core
Networking: IMAP
--
critical
RESOLVED WORKSFORME
9 years ago
9 years ago

People

(Reporter: whimboo, Unassigned)

Tracking

1.8 Branch
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.18pre) Gecko/20080926 Thunderbird/2.0.0.17pre Mnenhy/0.7.5.0 ID:2008100103

Thunderbird was running in background while an IMAP account was selected. It crashed suddenly.

Here the crashed thread from the Apple Crash reporter:

Process:         thunderbird-bin [11863]
Path:            /Applications/Thunderbird.app/Contents/MacOS/thunderbird-bin
Identifier:      org.mozilla.thunderbird
Version:         2.0.0.18pre (2.0.0.18pre)
Code Type:       X86 (Native)
Parent Process:  launchd [1]

Date/Time:       2008-10-02 22:47:23.689 +0200
OS Version:      Mac OS X 10.5.5 (9F33)
Report Version:  6

Exception Type:  EXC_BAD_ACCESS (SIGBUS)
Exception Codes: KERN_PROTECTION_FAILURE at 0x0000000095b585b0
Crashed Thread:  0

Thread 0 Crashed:
0   libSystem.B.dylib             	0x95b41558 tiny_malloc_from_free_list + 62
1   libSystem.B.dylib             	0x95b41c0b szone_calloc + 241
2   libSystem.B.dylib             	0x95b41ad5 malloc_zone_calloc + 88
3   libSystem.B.dylib             	0x95b41a62 calloc + 62
4   org.mozilla.thunderbird       	0x000f2dfd nsMsgImapLineDownloadCache::nsMsgImapLineDownloadCache() + 81
5   org.mozilla.thunderbird       	0x000fb040 nsImapProtocol::nsImapProtocol() + 506
6   org.mozilla.thunderbird       	0x00022464 PatriciaInsert + 30234
7   libxpcom_core.dylib           	0x00e49eac nsComponentManagerImpl::CreateInstance(nsID const&, nsISupports*, nsID const&, void**) + 144
8   libxpcom_core.dylib           	0x00e0f570 CallCreateInstance(nsID const&, nsISupports*, nsID const&, void**) + 60
9   org.mozilla.thunderbird       	0x001a5266 nsImapIncomingServer::CreateProtocolInstance(nsIEventQueue*, nsIImapProtocol**) + 148
10  org.mozilla.thunderbird       	0x001aa78e nsImapIncomingServer::GetImapConnection(nsIEventQueue*, nsIImapUrl*, nsIImapProtocol**) + 1340
11  org.mozilla.thunderbird       	0x001ab376 nsImapIncomingServer::GetImapConnection(nsIEventQueue*, nsIImapUrl*, nsIImapProtocol**) + 4388
12  org.mozilla.thunderbird       	0x000c5e7e nsImapService::GetImapConnectionAndLoadUrl(nsIEventQueue*, nsIImapUrl*, nsISupports*, nsIURI**) + 292
13  org.mozilla.thunderbird       	0x000cb102 nsImapService::FolderCommand(nsIEventQueue*, nsIMsgFolder*, nsIUrlListener*, char const*, int, nsIURI**) + 530
14  org.mozilla.thunderbird       	0x000cb34b nsImapService::FolderCommand(nsIEventQueue*, nsIMsgFolder*, nsIUrlListener*, char const*, int, nsIURI**) + 1115
15  org.mozilla.thunderbird       	0x0013ed0a nsImapMailFolder::CreateStorageIfMissing(nsIUrlListener*) + 1226
16  org.mozilla.thunderbird       	0x001a3c05 nsImapIncomingServer::GetFormattedStringFromID(unsigned short const*, int, unsigned short**) + 1423
17  org.mozilla.thunderbird       	0x00138eb3 nsImapMailFolder::GetDatabase(nsIMsgWindow*) + 2031
18  org.mozilla.thunderbird       	0x001a3e06 nsImapIncomingServer::GetFormattedStringFromID(unsigned short const*, int, unsigned short**) + 1936
19  org.mozilla.thunderbird       	0x00150752 nsMsgBiffManager::PerformBiff() + 584
20  org.mozilla.thunderbird       	0x00150845 OnBiffTimer(nsITimer*, void*) + 17
21  libxpcom_core.dylib           	0x00e4f77d nsTimerImpl::Fire() + 187
22  libxpcom_core.dylib           	0x00e4ff4f handleTimerEvent(TimerEventType*) + 107
23  libxpcom_core.dylib           	0x00e4c54d PL_HandleEvent + 21
24  libxpcom_core.dylib           	0x00e4c806 PL_ProcessPendingEvents + 103
25  com.apple.CoreFoundation      	0x96927615 CFRunLoopRunSpecific + 3141
26  com.apple.CoreFoundation      	0x96927cf8 CFRunLoopRunInMode + 88
27  com.apple.HIToolbox           	0x93c33480 RunCurrentEventLoopInMode + 283
28  com.apple.HIToolbox           	0x93c33299 ReceiveNextEventCommon + 374
29  com.apple.HIToolbox           	0x93c91d4e _AcquireNextEvent + 58
30  com.apple.HIToolbox           	0x93c904ab RunApplicationEventLoop + 207
31  org.mozilla.thunderbird       	0x0036edb7 nsAppShell::~nsAppShell() + 133
32  org.mozilla.thunderbird       	0x003d919a nsAppStartup::DestroyExitEvent(PLEvent*) + 148
33  org.mozilla.thunderbird       	0x00005ec6 XRE_main + 5892
34  org.mozilla.thunderbird       	0x00002ad0 main + 32
35  org.mozilla.thunderbird       	0x00002a56 start + 270
36  org.mozilla.thunderbird       	0x00002971 start + 41

Source location:
http://hg.mozilla.org/comm-central/annotate/525ea0a20b19/mailnews/imap/src/nsImapProtocol.cpp#l209

As Mark mentioned this could be a out of memory crash. Which could probably be the reason. I had opened several memory consuming applications so less memory was available.

Comment 1

9 years ago
i'd normally favor heap corruption over oom. can someone get me the source for tiny_malloc_from_free_list ?
(Assignee)

Updated

9 years ago
Product: Core → MailNews Core
(Reporter)

Comment 2

9 years ago
I haven't seen this crash anymore since I've reported it. But meanwhile I'm using Shredder. Probably it's only happening on branch and not trunk or seems to be a bit harder to reproduce.

Comment 3

9 years ago
(In reply to comment #2)
> I haven't seen this crash anymore since I've reported it. But meanwhile I'm
> using Shredder. Probably it's only happening on branch and not trunk or seems
> to be a bit harder to reproduce.

no hits on crash-stats for past 4 months, and no hits on talkback going back to 2009-02-11. so I'd say it's a one-off, and possibly even stack is invalid.

close?

Comment 4

9 years ago
sure, marking it wfm.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.