Closed Bug 458311 Opened 14 years ago Closed 14 years ago

Make XHR on a worker behave identically to XHR on the main thread

Categories

(Core :: DOM: Core & HTML, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla1.9.1b2

People

(Reporter: bent.mozilla, Assigned: bent.mozilla)

References

Details

There are a few things we have to do to make XHR on a worker behave the same as XHR on the main thread. This bug tracks them.
Gonna call this closed now.
Status: ASSIGNED → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
This is NOT solved! Or is there more then one kind of "workers" (HTML5 webworker)?

With Firefox 18.0.1 my (web)workers still sends XHR request different from them send in the main process, ending in different "sessions" on the server. It seems no session/cookie-information is included.

After adding the Cookie-Header manually to the worker-request the problem is gone. So theres still something wrong!

Filed it already as Bug 833265
Component: DOM: Mozilla Extensions → DOM
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.