Browser misidentifies the OS as XP instead of Vista

RESOLVED WORKSFORME

Status

()

Firefox
Shell Integration
RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: Enzo, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3

Firefox misidentifies the OS, which is both apparent in the theme (alternate button colors, etc) and with any websites that attempt to tell me my OS or otherwise use the browser's OS info (ex: on this very bug form, the operating system drop down was auto set to XP instead of Vista because of bad information from my browser).  Happens randomly as far as I can tell.
Unsure as to whether this is related or not, but this only started happening AFTER I installed Office 2007.

Reproducible: Sometimes

Steps to Reproduce:
1. ???
2. Start firefox
Actual Results:  
Firefox misreads OS.

Expected Results:  
Firefox should have been able to tell that I was running Vista

I stripped down all of my add-ons and the bug was not resolved.

Comment 1

10 years ago
From your user-agent string: "Windows NT 5.1" is XP
Windows NT 6.0 is Vista, so either you're using a useragent switcher, manually overriding the values in about:config or lying (or being lied to by your system)
If an application that is in XP compatibility mode launches Firefox or the shortcut or binary has been set to XP compatibility mode then Firefox will think that XP is the current OS. Chances are this is what's happening but the culprit still needs to be identified and the most likely culprit would be an app that is in XP compatibility mode is launching Firefox since it doesn't happen consistently... though it could be a specific shortcut.

Could you try to narrow down when specifically this happens? I am pretty sure this would only happen when Firefox is initially launched so it must not be running when trying to narrow it down.

(In reply to comment #1)
> From your user-agent string: "Windows NT 5.1" is XP
> Windows NT 6.0 is Vista, so either you're using a useragent switcher, manually
> overriding the values in about:config or lying (or being lied to by your
> system)
The useragent will also report XP on Vista when Firefox is running in compatibility mode.

Comment 3

10 years ago
oops I missed the Office 2007 thing. It might come with .NET 3.5 which apparently can change your user-agent string without permission.
See http://blog.tiensivu.com/aaron/categories/56-Info-Worker
That doesn't appear to change the OS version in the useragent and comment #2 still applies.
http://www.hanselman.com/blog/default.aspx?date=2008-09-08
(Reporter)

Comment 5

10 years ago
Alright.  Comment #2 was correct: I was launching firefox through a program that I had put into compatibility mode (AOL Instant Messenger 5.9.x).  I verified this by closing firefox and launching it through a link in an instant message.  Sorry about the fuss guys, thanks for the comments.  I simply hadn't noticed!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Resolution: FIXED → WORKSFORME

Comment 6

10 years ago
rs: can we detect this state and warn the user?
(In reply to comment #6)
> rs: can we detect this state and warn the user?
We could by reading the registry and comparing major version with the one returned by GetVersionEx. I suspect that the number of people that do this intentionally is not much smaller than the number of users that run into this unintentionally and that both numbers are relatively small.
You need to log in before you can comment on or make changes to this bug.