Closed Bug 458335 Opened 13 years ago Closed 12 years ago

If auto-compacting occurs while reading messages, 'Delete' icon no longer works

Categories

(Thunderbird :: Folder and Message Lists, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 224825

People

(Reporter: tim, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.17) Gecko/20080829 Firefox/2.0.0.17
Build Identifier: Thunderbird 2.0.0.17

This is not a new problem.  I've been experiencing this for at least several months.  But it's only been recently that I think I've figured out the details below.  For longer than I can remember, it's just seemed like some sessions the DeleteMessage "X" in the message-viewing window worked, and some sessions it didn't.

When I open Thunderbird and download messages, it seems like Thunderbird waits til I delete one message and then runs its compactor routine.  That's okay if I quit back to the list, then deleted the message, and then the compactor ran.  But if I'm going thru several messages and just hit the DeleteMessage "X" icon to delete that one and go to the next, and if the compactor runs while I'm reading one of those messages, then the "X" (delete message) icon quits working.  Then, for the rest of the session, I have to read the message, quit the message, THEN delete the message, then open the next message.



Reproducible: Always

Steps to Reproduce:
1. Start session
2. Download messages
3. Start reading messages
4. Delete message using the DeleteMessage icon in the message-viewing window
5. While viewing subsequent message, the Compactor runs
6. The DeleteMessage icon no longer works.

Actual Results:  
6a. Most of the time, I then have to quit back to the list of messages and delete the message from there.
6b. Sometimes it APPEARS to not work, but when I quit back to the list, that message I tried unsuccessfully to quit out of is now gone from the list.

Expected Results:  
That message should disappear (like it does at other times) and the next message would be displayed in the viewing window.  [NOTE: This is a separate window.  For safety reasons, I NEVER allow the "message pane" (that shares the screen with the list of messages) to be open.]
sounds like dupe of bug 224825
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Component: General → Folder and Message Lists
QA Contact: general → folders-message-lists
Resolution: --- → DUPLICATE
Version: unspecified → 2.0
Duplicate of bug: 224825
You need to log in before you can comment on or make changes to this bug.