I postponed reoccuring event alarm closing closes also the second occurence

VERIFIED DUPLICATE of bug 397030

Status

VERIFIED DUPLICATE of bug 397030
10 years ago
10 years ago

People

(Reporter: jontto, Unassigned)

Tracking

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-GB; rv:1.9.0.3) Gecko/2008092414 Firefox/3.0.3
Build Identifier: Stable release 0.9 of lightning

I'm using the Google Calendar provider. I have an event that occurs every month and gives and alarm on the screen. However if I postpone the alarm 1 day at a time until the next one also goes off (one month later) I'll get two alarm instances popping up: one for the old and one for the new. If I now try to dismiss the old one, so I can just postpone the new one again (yeah, I'm lazy ;-) it will actually close both the old and the new alarm at once.

Reproducible: Didn't try

Steps to Reproduce:
1. Set re-occuring alarm
2. Sleep for 1 day at time until next occurence goes off
3. Try to dismiss only the first alarm
Actual Results:  
Both occurences are dismissed.

Expected Results:  
Only the first occurence should be dismissed. I want to be able to sleep the new occurence normally.

As I said. I'm using Google Calendar provider and might be that the events are set on the webpage, not necessarily in Lightning.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 397030

Updated

10 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.