Closed Bug 45837 Opened 24 years ago Closed 24 years ago

Uncaught exception printed out on terminal chrome://navigator/content/nsContextMenu.js Line: 271

Categories

(Core :: DOM: UI Events & Focus Handling, defect, P3)

x86
Linux
defect

Tracking

()

VERIFIED DUPLICATE of bug 27289

People

(Reporter: wtanaka, Assigned: joki)

References

()

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.0-test1 i686; en-US; m17) Gecko/20000717
BuildID:    2000071720

The following error message prints out on the terminal:

JavaScript error:
 line 0: uncaught exception: [Exception... "Method not implemented"  code:
"-2147467263" nsresult: "0x80004001 (NS_ERROR_NOT_IMPLEMENTED)"  location:
"chrome://navigator/content/nsContextMenu.js Line: 271"]


Reproducible: Always
Steps to Reproduce:
0. visit a page that does not fit vertically in the browser window
1. Left click and hold on the main browser scrollbar on the right hand side of
the browser window
2. Right click while the left button is still held down.
3. (examine terminal output)

Actual Results:  The following message was printed on the terminal:
JavaScript error:
 line 0: uncaught exception: [Exception... "Method not implemented"  code:
"-2147467263" nsresult: "0x80004001 (NS_ERROR_NOT_IMPLEMENTED)"  location:
"chrome://navigator/content/nsContextMenu.js Line: 271"]


Expected Results:  No message should be printed
marking dup of bug 27289 "scrollbar context menu loads last context menu"
That is what is "trying" to take place when you right-click scrollbar, and
testing with linux build ID 2000-071808, it still occurs.

I added a comment in bug 27289 about the js error output to console, but i
believe that matter is also well known. (JS errors are mentioned in one of the
dups of it (28529))

*** This bug has been marked as a duplicate of 27289 ***
Status: UNCONFIRMED → RESOLVED
Closed: 24 years ago
Resolution: --- → DUPLICATE
Mass update:  changing qacontact to ckritzer@netscape.com
QA Contact: janc → ckritzer
Updating QA Contact.
QA Contact: ckritzer → lorca
Verified dupe.
Status: RESOLVED → VERIFIED
Component: Event Handling → User events and focus handling
You need to log in before you can comment on or make changes to this bug.