Firefox "updates" to older version

RESOLVED WORKSFORME

Status

Firefox Graveyard
Microsummaries
RESOLVED WORKSFORME
10 years ago
3 years ago

People

(Reporter: Siyivan, Unassigned)

Tracking

3.0 Branch
x86
Windows XP

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; es-ES; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3
Build Identifier: 

Today Firefox 3.0.2 stopped and was using 100% CPU. I hadn't asked it to load a heavy page so after a little I killed it. When it restarted, it had found an update and installed it. When it opened, it was 'updated' to Firefox 3.0 beta 2 (I was on 3.0.2) and the address bar showed broken (urls were shown on a new second textbox).

I manually asked it to search for updates, and it successfully downloaded and installed Firefox 3.0.3

My guess is that the cpu increase was due to the autoupdate (it was decompressing something?) and when restarted it picked some old files (I had previously installed FF3b2, but went through beta 3, 3, 3.0.1, 3.0.2 without issues).


Reproducible: Didn't try

Steps to Reproduce:
1.
2.
3.

Comment 1

10 years ago
It sounds like you had an issue with the old beta you had installed. Were they in the same directory? I don't think we can repo this, so I'll search for dupes.
Component: Installer → Microsummaries
QA Contact: installer → microsummaries
Whiteboard: DUPEME
Version: unspecified → 3.0 Branch
(Reporter)

Comment 2

10 years ago
I started installing the betas on a different folder, and then on the normal Firefox folder. Looking at them, seems that I might have launched an old FF3b2 install which would then show the odd address bar due to incomparibilities with a newer 3.0.3 profile.
So if this looks reasonable and there aren't duplicates, close INVALID.

Comment 3

10 years ago
No dupe so far, soo looks like WFM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME

Updated

5 years ago
Whiteboard: DUPEME
(Assignee)

Updated

3 years ago
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.