Cannot update or grab new Themes - get error message (listed in details box).

RESOLVED DUPLICATE of bug 437174

Status

()

Toolkit
Add-ons Manager
RESOLVED DUPLICATE of bug 437174
10 years ago
10 years ago

People

(Reporter: snowedin, Unassigned)

Tracking

1.9.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3

I cannot update or grab new Themes in Mozilla Firefox.  

Most of the Themes listed under "Add-ons" are disabled as "not compatible with Firefox 3.0.3"  Because of that, I decided to look for new themes & see if some of the themes I had did have updates.  

Tried downloading both updated themes & new themes.  I'd press install, and each and every time I got back an "invalid file hash" error message.  I copied one of them below.  Could you please let me know if there is a fix for this?

ERROR MESSAGE:

Firefox could not install the file at 

https://addons.mozilla.org/en-US/firefox/downloads/file/37417/boston_celtics__home_-1.2.0-fx.jar

because: Invalid file hash (possible download corruption)
-261


Reproducible: Always

Steps to Reproduce:
1. tried downloading arctic glow theme
2. tried downloading Boston Celtics theme
3. tried downloading glowy blue theme
Actual Results:  
Firefox could not install the file at 

https://addons.mozilla.org/en-US/firefox/downloads/file/37417/boston_celtics__home_-1.2.0-fx.jar

because: Invalid file hash (possible download corruption)
-261

Expected Results:  
Should have installed the new theme & been available under "Add-ons" Themes tab.

The themes I was trying to download were not all from the same creator.
Component: Theme → Add-ons Manager
Product: Firefox → Toolkit
QA Contact: theme → extension.manager
Version: unspecified → 1.9.0 Branch
Please clear your cache and try again in about an hours time.
(Reporter)

Comment 2

10 years ago
Clearing the cache did not work.

I just tried downloading 2 again & got the same error message:


Firefox could not install the file at 

https://addons.mozilla.org/en-US/firefox/downloads/file/38447/arctic_glow-3.1.2.1-fx.jar

because: Invalid file hash (possible download corruption)
-261

Firefox could not install the file at 

https://addons.mozilla.org/en-US/firefox/downloads/file/37417/boston_celtics__home_-1.2.0-fx.jar

because: Invalid file hash (possible download corruption)
-261


>>>>>>> Any other solutions?
Instead of clicking "Add to Firefox", right click it and choose "Save Link As...". Save the file somewhere and then attach it to this bug report.

Let us know which of the two you mention that you do this for.
(Reporter)

Comment 4

10 years ago
I tried your suggestion on both themes listed in this thread...  Unfortunately it did not work.

When I right click on "Add to Firefox" button & select "Save Link As," I get the following:

Filename:  login
Save as Type:  Firefox document

This should have been a .jar file instead, am I correct?

Upon emailing one of the theme creators about this error, he was kind enough to email me the .jar file (for the Boston Celtics theme).  I saved the .jar file to my pc, and then dragged/dropped it onto my open "Add Ons" window in Firefox - it installed just fine & is works great (I'm currently using it).  So now we know there's not a problem with that theme...  I cannot vouch for the other theme, as the creater of "Arctic Glow" gave me a bad page link (got "404 - Page Not found" when I clicked on it) to the themes he said he uploaded to his site.

I hope you can come up with a fix for those 2 themes...  I tried downloading the Rain theme & it worked fine, which I found odd.
Do you have the box ticked to accept third party cookies in options - privacy?
(Reporter)

Comment 6

10 years ago
No - the 3rd party cookies option is unchecked (on purpose).  However, I did go into "Exceptions" and placed " addons.mozilla.org* " on the list, clicking "Allow."

FYI - just tried downloading the "Green Aqua" theme & got this: 

Firefox could not install the file at 

https://addons.mozilla.org/en-US/firefox/downloads/file/32236/green_aqua-1.0.38-fx.jar

because: Invalid file hash (possible download corruption)
-261

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 437174
You need to log in before you can comment on or make changes to this bug.