If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Cannot build with --disable-detect-webshell-leaks (nsWebShell.cpp:1433)

VERIFIED WORKSFORME

Status

SeaMonkey
Build Config
P3
normal
VERIFIED WORKSFORME
17 years ago
13 years ago

People

(Reporter: Decklin Foster, Assigned: cls)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
If I ./configure with the --disable-detect-webshell-leaks (or simply omit it, as
disabled is the default) I can no longer build (as of 5AM PDT 07/19). I get the
following error:

nsWebShell.cpp: At top level:
nsWebShell.cpp:1433: `long unsigned int
nsWebShell::gNumberOfWebShells' is not a static member of `class nsWebShell'
make[2]: *** [nsWebShell.o] Error 1

the offending line is here:
http://lxr.mozilla.org/seamonkey/source/docshell/base/nsWebShell.cpp#1433

As you can see, it's bracketed off by #ifdef DETECT_WEBSHELL_LEAKS, which gets
defined even if we have disabled it. Therefore I am guessing that the error is
in the configure script.
(Assignee)

Comment 1

17 years ago
Hmm. We appear to unconditionally define DETECT_WEBSHELL_LEAKS.  It appears that
change was made a while ago.  At any rate, I can't reproduce the bustage. 
jdunn's fix for aix may have fixed this.  Marking worksforme.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

17 years ago
Verifying that this has been fixed since the 19th. Thanks.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.