[EVENTTARG]Hidden <DIV>s make M16 behave strange

VERIFIED DUPLICATE of bug 42356

Status

()

Core
Event Handling
P3
normal
VERIFIED DUPLICATE of bug 42356
18 years ago
18 years ago

People

(Reporter: Martin Eriksson, Assigned: joki (gone))

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
<DIV>s must be positioned BEFORE they become visible. Just placing
hidden <DIV>s anywhere in the document without positioning values (and later,
with javascript give them CSS STYLE positioning values that would make parts of
the <DIV> appear outside the original loaded document) make mozilla behave
strange. (strange = nothing happends when you press links for example, and in
Netscape 6 the whole page become "dead" (coursor didn't change when moving over
links, values could not be entered in text boxes etc.. In M16 the couror changes
when over links but nothing happends when you press them)), therefore you have
to give hidden <DIV>s style vaules like this:
#divTag  {position:absolute; left: 300; top:330; width:455; visibility:
hidden;}
or
<div id="divTag" STYLE="position:absolute; left: 300; top:330; width:455;
visibility: hidden;">
So netscape will know in advance where the <DIV> will appear.
example:
http://www.decklab.com/bugz/pos.php
I don't know wheater this was bad coding from me or a mozilla "bug".
Netscape 4.7 in windows will not show the entire <DIV> tag (unless pre
positioned when hidden) because no scrollbars appear when the <DIV> become
visible.
If not pre positioned when hidden, the longer <DIV> crash Netscap 4.7 in
linux when page is loaded.
Internet Explorer 5 adds scrollbars to the page if the <DIV> is not visible in
the original loaded document.

Comment 1

18 years ago
Could you please download a newer build of Mozilla to try your page out with
(ftp://ftp.mozilla.org/pub/mozilla/nightly/latest/).  Also, I tried to load the
page in IE5, but it gave me a whole lot of errors.  This seems to me that it's a
JS problem, not a Mozilla one.
(Reporter)

Comment 2

18 years ago
I've updated the pages to my latest version. One page with positioning:
http://www.decklab.com/bugz/pos.php
And one page without positioning.
http://www.decklab.com/bugz/nopos.php
The pages use a serverside script to find out what client you use.
On the nopos.php page you'll find out the following when pressing the 
link "Bidding and Selling" in 1024x768:
IE5: adds lenght to the existing scrollbar.
NE4.7: You can't see all the <DIV>. Scrollbar not long enough.
NE6 pre1: Coursor doesn't change over any links and you can't enter values in 
text boxes
M16: Coursor changes over links but nothing happens when pressed. 
Mozilla build ID 2000071910: Same as M16
Internet Explorer won this round. 

When you visit pos.php you'll see that everything works as it should. 

I think this is a very dangerous behaviour. Many developers rely on dynamic CSS 
positioning, and sometimes you don't always know how big <DIV>s you need to 
show/hide. 
I think (hope) this is a duplicate of bug 42356.
Assignee: clayton → joki
Component: HTML Element → Event Handling
QA Contact: petersen → janc
Summary: Hidden <DIV>s make M16 behave strange → [EVENTTARG]Hidden <DIV>s make M16 behave strange

Comment 4

18 years ago
seems like a dupe of 42356 to me after i read the bugs that are already dupes of
42356

*** This bug has been marked as a duplicate of 42356 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 5

18 years ago
Mass update:  changing qacontact to ckritzer@netscape.com
QA Contact: janc → ckritzer

Comment 6

18 years ago
Updating QA Contact.
QA Contact: ckritzer → lorca

Comment 7

18 years ago
verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.