Diff lines overlapping in long lines

VERIFIED WORKSFORME

Status

()

Bugzilla
Attachments & Requests
--
minor
VERIFIED WORKSFORME
9 years ago
9 years ago

People

(Reporter: Tyler, Unassigned)

Tracking

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b1pre) Gecko/20081003 Minefield/3.1b1pre
Build Identifier: 

I will attach a screenshot later. When this diff is viewed, several lines overlap from the original column to the new column. Specifically, some of these exhibiting this are lines 56 and 57 on the top file (it happens in several other places). Zoom is at normal. It seems that the line endings are longer that the viewable area, so it overlaps. This is most likely not the best solution. Maybe breaking it down to the next line, but with a line continuation mark.

Reproducible: Always

Steps to Reproduce:
1.Visit given URL
2.View Lines 56, 57

Actual Results:  
Lines overlap next column. 

Expected Results:  
No overlap.
(Reporter)

Comment 1

9 years ago
Created attachment 341711 [details]
Screenshot of the line overlap

Comment 2

9 years ago
There is something wrong with your Fx profile. Lines should correctly wrap, at least in Firefox. Visiting the link above, I can see long lines being wrapped, in Fx 3.0.3 and Fx 3.1b1pre. But it indeed doesn't wrap correctly using Opera 9.52.
Assignee: ui → attach-and-request
Severity: normal → minor
Component: User Interface → Attachments & Requests
OS: Windows Vista → All
Hardware: PC → All
Version: unspecified → 3.2
(Reporter)

Comment 3

9 years ago
OK, I will check with a new profile, though this one is fresh, so I don't see that, but will double-check.
(Reporter)

Comment 4

9 years ago
I tried in a new profile with no changes. The overlapping issue is still there. Do you think this is a FF bug? I am using Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b1pre) Gecko/20081004 Minefield/3.1b1pre FYI.

Comment 5

9 years ago
Yeah, I can't reproduce it either.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME

Comment 6

9 years ago
(In reply to comment #4)
> Do you think this is a FF bug?

Doubtful, unless it's specific to Firefox on Windows. But as I said, I can reproduce with Opera, so reopening.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Reporter)

Comment 7

9 years ago
Now that bmo has been upgraded, to 3.2RC2, I am not seeing this issue. I will close for now.
Status: REOPENED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 8

9 years ago
Not seeing anymore.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.