Dim composer Save button when message is in saved state

RESOLVED WONTFIX

Status

SeaMonkey
MailNews: Composition
--
enhancement
RESOLVED WONTFIX
10 years ago
5 years ago

People

(Reporter: Fred Yontz, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.17) Gecko/20080829 MultiZilla/1.8.3.4e SeaMonkey/1.1.12
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.17) Gecko/20080829 MultiZilla/1.8.3.4e SeaMonkey/1.1.12

There is no indication when a message in Composer is in a saved state (can be closed without saving again). I request that the toolbar Save button be dimmed when the message is in a saved state, similar to the way the Spell button is dimmed when focus is not in the message body window. 

(Having an indicator of saved/unsaved state is common to not only editors, but most all content creation applications.)

Reproducible: Always

Updated

10 years ago
Component: General → Composer
QA Contact: general → composer

Updated

7 years ago
Status: UNCONFIRMED → NEW
Component: Composer → MailNews: Composition
Ever confirmed: true
OS: Windows 2000 → All
QA Contact: composer → mailnews-composition
Hardware: x86 → All
Version: unspecified → Trunk

Comment 1

7 years ago
I'm not sure how possible this is due to the fact the Save button is a menu button, so even if the message has been saved the user might still want to do a save as of some sort.
In theory we could set the enablement of the Save menuitem in the file menu depending on if the message has been changed since the last save but that might cause issues with the Save button.

Comment 2

7 years ago
With the current buttons, this is a WONTFIX unfortunately. If a button which is Save only gets added then that would be possible to dim.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 3

6 years ago
I keep running into this deficiency (unknown save status) almost every time I compose a message.  How about adding a "Save as" button as the menu button, and make the Save button solely for save as draft, dimmed when in saved state.
(Reporter)

Comment 4

6 years ago
Elaborating on my previous comment, the message compose window has in its File menu both "Save" and "Save As" options, so adding a "Save As" button alongside the "Save" button on the toolbar would be consistent with options under the File menu, and would allow dimming the "Save" toolbar button when the message is in a saved state.
(Reporter)

Comment 5

5 years ago
I am disappointed in not seeing any response to my previous comment about reflecting the File menu structure of options "Save" and "Save As" in toolbar options of the same names.  Maybe it's too difficult, or maybe no one else finds not knowing the save status of an open message window even a minor annoyance, but it seems to me to be a structural disparity that ought to be remedied.  If I weren't 76 and struggling with depression, I'd learn how and make this change myself.
You need to log in before you can comment on or make changes to this bug.