Closed Bug 458514 Opened 14 years ago Closed 7 years ago

Bookmark Manager can import bookmarks from Thunderbird

Categories

(SeaMonkey :: Bookmarks & History, defect)

x86
Windows Vista
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: JasnaPaka, Unassigned)

Details

Attachments

(1 file)

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b1pre) Gecko/20081004 SeaMonkey/2.0a2pre

Steps to reproduce:
1) Open Bookmark Manager.
2) Choose Tools -> Import in menu.
3) You can see that SeaMonkey can import bookmarks from Thunderbird.

I don't think this is a good choice.
I can confirm this with WindowsXP, add an Screenshot from Import-Wizard Popup and DOMI to describe the wrong Label.

But on my other Win2k-System the "Import from" Label was set right to "SeaMonkey 1xx, Netscape[..]" and so. 

So it seems, that sometimes the migration-wizard gets a wrong wrong label for the Radiobox, and in other cases not.
(In reply to comment #1)
> Created an attachment (id=375014) [details]
> Screenshot from Wizard and DOMI
[...]
> So it seems, that sometimes the migration-wizard gets a wrong wrong label for
> the Radiobox, and in other cases not.

Or the Migration Wizard took the wrong radiogroup? CC'ing Stabdard8 and KaiRo, hope they know more.
Status: UNCONFIRMED → NEW
Ever confirmed: true
This happens on MacOS X 10.5.x too, have not tested on 10.4.x and on Linux yet. 

Using DOMI for the Import-Wizard (migration.xul) on WinXP the under the radiogroup with id "importSourceGroup" the "radio" "seamonkey" has got the nodeName "hidden" with value "true", but this nodeName does not exist for the "radio" "thunderbird", so this was displayed in the Import-Wizard-Popup-Window.
Well in theory we should display Netscape/SeaMonkey 1.x if one of their profiles exist.

Could it be that we don't have a Netscape/SeaMonkey 1.x profile installed and its getting confused and displaying Thunderbird instead?
That may be right. On all my tested Systems were: 

"Import Bookmarks from: 
[ ]Thunderbird 
[ ]File" 

will be displayed, no Netscape/SeaMonkey 1.x Profiles exist. 
In Difference to the Win2k-System, were I get the right Items, there exist an SeaMonkey 1.1.x-Profile.
In which case, its probably something to do with http://mxr.mozilla.org/comm-central/source/suite/profile/migration.js#101 (onImportSourcePageShow). I haven't got time to look into it at the moment.
I can't get a reason behind original report, why presence of migration bookmarks from Thunderbird is bad?
Whiteboard: [2012 Fall Equinox]
(In reply to Phoenix from comment #7)
> I can't get a reason behind original report, why presence of migration
> bookmarks from Thunderbird is bad?

Maybe because Thunderbird _has_ no bookmarks?
The Migration Wizard was dropped in December 2011, see bug 689437.  Under SM 2.33 the Bookmarks Manager has only a Import HTML… tool.  So this was fixed.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Whiteboard: [2012 Fall Equinox]
You need to log in before you can comment on or make changes to this bug.