TM: Assertion failed: "need a way to EOT now, since this is trace end"

RESOLVED WORKSFORME

Status

()

Core
JavaScript Engine
--
critical
RESOLVED WORKSFORME
9 years ago
9 years ago

People

(Reporter: Jesse Ruderman, Unassigned)

Tracking

(Blocks: 1 bug, {assertion, regression, testcase})

Trunk
x86
Mac OS X
assertion, regression, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
$ ./js -j
js> for (var j = 0; j < 2; ++j) { if (3 | 3) { } }

Assertion failed: "need a way to EOT now, since this is trace end": 0 (nanojit/LIR.cpp:871)

Why is two loop iterations enough to trigger the tracer here?

Comment 1

9 years ago
WFM with TM tip. Closing bug since this was not user-reported.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

9 years ago
Yep, WFM.
You need to log in before you can comment on or make changes to this bug.