new event -> "show time as" misses Out of office option

RESOLVED WONTFIX

Status

Calendar
General
--
minor
RESOLVED WONTFIX
10 years ago
6 years ago

People

(Reporter: Przemyslaw Bialik, Unassigned)

Tracking

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.1b1pre) Gecko/20081004 Lightning/1.0pre Shredder/3.0b1pre

New event -> Options -> "show time as" misses Tentative & Out of office options.

Reproducible: Always

Steps to Reproduce:
1. Create new event
2. Options -> Show Time as
3. Choose Tentative or Out of office
Actual Results:  
Not available.

Expected Results:  
Available.

The same should also apply to the tasks and be displayed in the freebusy-timebar.
The status 'tentative' can be selected from Options -> Status. 

The support for free/busy time type tentative is already requested with Bug 415247.
(Reporter)

Comment 2

10 years ago
Thanks, so I guess Out of office = BUSY-UNAVAILABLE (got the idea from Outlook) and assuming freebusy-timebar and "show time as" would provide both of them then this is a duplicate.
(Reporter)

Comment 3

10 years ago
cc-ing simon who worked on similar bug
Flags: wanted-calendar1.0?
Summary: new event -> "show time as" misses Tentative & Out of office options → new event -> "show time as" misses Out of office option
Version: unspecified → Trunk

Comment 4

10 years ago
First I should point out that the free busy information is generated by a server, so even if setting the "Show time as" to "BUSY" is generally a clear hint to the server that freebusy lookups should block that time range, it could be ignored and it would not be a bug. For example, you can see the definition of CALDAV:schedule-calendar-transp property in http://ietfreport.isoc.org/idref/draft-desruisseaux-caldav-sched/ . This property can be set on any calendar to decide if the meetings in that calendar will block time or not (no matter what the TRANSP property values of each meetings are).

The free busy information generated by a server usually depends on a few things:
- The TRANSP property, which can be OPAQUE or TRANSPARENT
- The STATUS property, which can be CONFIRMED, TENTATIVE or CANCELLED
- The Participation status of the attendee, (NEEDS_ACTION, ACCEPTED, DECLINED, TENTATIVE...).
- Other data in the event : ie: Day events with a CATEGORIES of "Holiday" might be considered as BUSY-UNAVAILABLE by default.

You can see section 7.10 of the CalDAV rfc for a simpler implementation: http://www.ietf.org/rfc/rfc4791.txt

Some servers like Oracle's and Apple's have "Available hours" that can be set using other clients than Sunbird/Lightning, see this draft:
http://www.ietf.org/internet-drafts/draft-daboo-calendar-availability-01.txt Doing a free busy lookup outside these available hours will return BUSY-UNAVAILABLE.

So while the Outlook feature of letting a user decide that a meeting should be shown as BUSY-UNAVAILABLE instead of BUSY is very interesting, and supported in non-standard ways by some servers, it cannot be implemented without adding a non-standard property or parameter which would most likely not inter-operate with many server since the server is the one generating the free-busy and it has to know about that value.

I don't think this bug can be resolved without someone initiating an effort to standardize an extended transparency support for iCalendar and asking for it to be supported by server implementers.
Simon, thanks for the reasoning. I think we should mark this bug WONTFIX until standards emerge for this aspect. Przemyslaw, if you disagree please reopen with further reasoning.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX
Flags: wanted-calendar1.0?
(Reporter)

Comment 6

10 years ago
Thank you simon for extended information!
So if TRANSP property sent by Lightning is only a hint because server generates free busy information and it can ignore the hint then is there a point of having new event -> options -> "show time as" available in the lightning ?
I could think about server-less installations of lightning to inform about the free busy status of the organizer but then this property is not shown in the UI of those invited (wondering if this could be useful to file enh bug).

So to summarize all servers supports returning BUSY_UNAVAILABLE value but not all of them supports setting it explicitly through the client because there is not yet standard for this.

Comment 7

10 years ago
What I said might have been a bit misleading, yes, setting this option is just a "hint" but this value is still used for generating the freebusy information MOST of the time, the behavior of all server implementations that I know of will take it into account by default and an OPAQUE meeting will result in a BUSY time slot in the freebusy report. Only when a user specifically sets his calendar transp to "transparent" will this setting be ignored at the meeting level. So it is a very useful feature. 

I would rephrase your last paragraph with: 

To summarize: Meeting properties can only affect free-busy information by changing time slots to "FREE", "BUSY" or "TENTATIVE". Most servers support returning BUSY-UNAVAILABLE value in a FREEBUSY lookup but these BUSY-UNAVAILABLE time slots are usually not derived from meetings because there is no standard way to get that information from a meeting.

Comment 8

6 years ago
Hello can you recheck if it is possible to create an events with the BUSY-UNAVAILABLE (Out of Office) state in lightning? Check the the following RFC:

RFC5545:
3.2.9. Free/Busy Time Type
busy-unavailable:
http://tools.ietf.org/html/rfc5545#section-3.2.9
You need to log in before you can comment on or make changes to this bug.