Closed Bug 458614 Opened 12 years ago Closed 12 years ago

Java Applet load error

Categories

(Core :: Plug-ins, defect)

1.9.0 Branch
x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: eddy_nigg, Unassigned)

References

()

Details

Attachments

(3 files)

When using the FileManager Applet as provided by Webmin an error occurs and the applet fails to load. Latest working version is current FF2, FF3 fails. 

- Status bar shows "Applet FileManager notinited".
- Connection is via secured site on non-default port (like port 4567).

Attaching error messages and screen shot.
Attachment #341835 - Flags: approval1.9.0.4?
Attachment #341835 - Flags: approval1.9.0.4?
Comment on attachment 341835 [details]
Error message after failure to load.

Approval flags are for patches you want to land on the branch.
Also, is this a Linux bug you're reporting? The JEP (Java Embedding Plugin) only applies to Mac OS X.
Does changing browser.cache.disk_cache_ssl to true makes it working ?
Oooops. I didn't knew exactly which "Java Something" component to choose, so this sounded about right...apparently not. Please move to matching component. 
Yes, this behavior is on Linux, not tested on other platforms, might apply too.

BTW, this is with the following JVM, but applies to current release and older JVM releases as well:

Java(TM) SE Runtime Environment (build 1.6.0_10-beta-b25)
Java HotSpot(TM) Server VM (build 11.0-b12, mixed mode)
(In reply to comment #4)
> Does changing browser.cache.disk_cache_ssl to true makes it working ?
No
-> Core::Plug-ins for now.
Assignee: smichaud → nobody
Component: Java Embedding Plugin → Plug-ins
QA Contact: java.jep → plugins
I opened this bug after the short discussion on bug 458545. Changing network
settings doesn't help either (not likely related I think).

BTW, I have no clue why all the output of "UlteoVNC" is in the error message,
but it's not related. A clean session doesn't have any effect.
Eddy:  You haven't provided specific steps to reproduce this bug.  Please do so (using the webmin site, or something on the webmit site).
Webmin is a commonly used web based application for managing Linux servers (remotely). One of the standard components is the Java based FileManager (Applet). Using it previously crashed FF3 or failed to load until shutting the browser, these days it creates an error.

In order to reproduce it, install Webmin on a Linux server and navigate with FF3 to the FileManager.
I work on the Java Plug-In at Sun Microsystems. Can you try to determine whether this is a bug on the Firefox or Java Plug-In side by switching between the classic Java Plug-In (libjavaplugin_oji.so) and the new Java Plug-In (libnpjp2.so)? If the error occurs only with the new Java Plug-In, it is likely a regression on the Java side. If it occurs with both versions of the Java Plug-In in Firefox 3, but does not occur in Firefox 2 with the classic Java Plug-In (which is the only version Firefox 2 supports), it is likely a regression on the Firefox side.
It happens with both libraries. Actually I didn't knew about the new one and only used the classic one always. Checked now also the new one and the only difference was that FF this time crashed :-)
Attaching the bug report as well...

To confirm, this applet works with FF2 (and previous), old and new Java plugins fail to load, error or crash. (Stupid me, I thought somebody will have reported this issue already..I'm pretty bad in searching existing bugs, should have reported it much earlier since I ran FF3 nightlies).
Attached file Crash output
(In reply to comment #10)

Anybody know of a publicly available URL that demos Webmin?

We (myself and other potential testers) would appreciate being able to avoid the trouble of having to set up Webmin ourselves, just to test for this bug.
Unfortunately I can't give access to the servers I've got. If you have a Linux box (even on a VM), it should be fairly easy to install the Webmin RPM or DEB package. From there accessing the file manager is a snap...
To my surprise the Webmin file manger Java applet worked today with version Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.3) Gecko/2008092416 Firefox/3.0.3

I have no clue what changed, but it works. Resolving WORKSFORME...
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.