Upgrade to 0.9 created new alarms for 200 events; repeating events cannot be dismissed

RESOLVED DUPLICATE of bug 494140

Status

Calendar
Alarms
--
major
RESOLVED DUPLICATE of bug 494140
9 years ago
8 years ago

People

(Reporter: David Birnbaum, Unassigned)

Tracking

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3
Build Identifier: 2008091719

I've upgraded on my main Lightning from 0.8 to 0.9.  After I did this, I got 200+ event reminders reappearing.  Attempted to dismiss, reminder count would scroll down to 0 then back to 200 for a while.  Got down to about 119, then stopped going down.  After repeated analysis, and disabling my main calendar, leaving only a side calendar, it appears that any repeating event with an alarm is now listed multiple times (since instantiation for recent events, not sure about how far back it goes).  An attempt to dismiss the event fails, the even simply comes back.  In my screen now, for example, I have two events, three iterations (three weeks for one, two weeks for the other).

HELP!  I moved all my calendaring into Lightning to test for production a few months ago, now my life is on hold....  :(  Have disabled alarms in the meantime.

Reproducible: Always

Steps to Reproduce:
Happened in upgrade from 0.8 to 0.9l not sure how to reproduce.  Note that I'd used 0.9pre on my laptop (with alarms disabled) from time to time, not sure if that has an impact or not.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 494140
You need to log in before you can comment on or make changes to this bug.