If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Dell 3110 laser printer causes crashes [@ XPCWrappedNative::GetNewOrUsed(XPCCallContext&, nsISupports*, XPCWrappedNativeScope*, XPCNativeInterface*, int, XPCWrappedNative**)]

RESOLVED WORKSFORME

Status

()

Core
XPConnect
--
critical
RESOLVED WORKSFORME
9 years ago
6 years ago

People

(Reporter: Brooke, Unassigned)

Tracking

({crash})

1.9.0 Branch
PowerPC
Mac OS X
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.3) Gecko/2008092414 Firefox/3.0.3
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.3) Gecko/2008092414 Firefox/3.0.3

If I open firefox and do a print 99% of the time everything works fine. If I do a second - or more, about half of the time it will crash. Right after I do a file - print where I would usually select the printer options, my default is a dell 3110, the system crashes. 

I have this on my MacBook Pro, a coworkers macbook pro, anothers imac 24" and a macbook. Others have reported the issue, all since the upgrade to v3.0.xxx of firefox. It worked with 2.x, all of us running latest patches of leopard. This is Dells latest driver, when printing to a different default or using a machine without this driver, all is well. When using firefox 2.x all is well, when using 3.0.x, it crashes pretty consistently after the first successful print. 

Reproducible: Always

Steps to Reproduce:
1. print - works
2. print again - crashes
3. profit 
Actual Results:  
crashes instead of prints

Expected Results:  
prints and doesn't crash

happy to help however I can! I try to submit the crash IDs...I will again once I get it to crash next time I print.
Brooke: Please type about:crashes in the URL bar and paste one of the crash IDs you have received.  Thanks.
(Reporter)

Comment 2

9 years ago
8fb98cba-947c-11dd-93e5-001a4bd43e5c
Just did that one this morning for you :)

Comment 3

9 years ago
Signature	XPCWrappedNative::GetNewOrUsed(XPCCallContext&, nsISupports*, XPCWrappedNativeScope*, XPCNativeInterface*, int, XPCWrappedNative**)
UUID	8fb98cba-947c-11dd-93e5-001a4bd43e5c
Time	2008-10-07 07:30:47-07
Uptime	263
Product	Firefox
Version	3.0.3
Build ID	2008092414
OS	Mac OS X
OS Version	10.5.5 9F33
CPU	x86
CPU Info	GenuineIntel family 6 model 15 stepping 10
Crash Reason	EXC_BAD_ACCESS / KERN_INVALID_ADDRESS
Crash Address	0xcee5a8
Comments	
Crashing Thread
Frame 	Module 	Signature [Expand] 	Source
0 	XUL 	XPCWrappedNative::GetNewOrUsed 	mozilla/js/src/xpconnect/src/xpcwrappednative.cpp:333
1 	XUL 	XPCConvert::NativeInterface2JSObject 	mozilla/js/src/xpconnect/src/xpcconvert.cpp:1106
2 	XUL 	XPCConvert::NativeData2JS 	mozilla/js/src/xpconnect/src/xpcconvert.cpp:479
3 	XUL 	XPCWrappedNative::CallMethod 	mozilla/js/src/xpconnect/src/xpcwrappednative.cpp:2479
4 	XUL 	XPC_WN_GetterSetter 	mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp:2254
5 	libmozjs.dylib 	js_Invoke 	mozilla/js/src/jsinvoke.c:1297
6 	libmozjs.dylib 	js_InternalInvoke 	mozilla/js/src/jsinvoke.c:1369
7 	libmozjs.dylib 	js_InternalGetOrSet 	mozilla/js/src/jsinvoke.c:1427
8 	libmozjs.dylib 	js_NativeGet 	mozilla/js/src/jsobj.c:3568
9 	libmozjs.dylib 	js_Interpret 	mozilla/js/src/jsinterp.c:4166
10 	libmozjs.dylib 	js_Invoke 	mozilla/js/src/jsinvoke.c:1313
11 	libmozjs.dylib 	js_InternalInvoke 	mozilla/js/src/jsinvoke.c:1369
12 	libmozjs.dylib 	js_InternalGetOrSet 	mozilla/js/src/jsinvoke.c:1427
13 	libmozjs.dylib 	js_NativeGet 	mozilla/js/src/jsobj.c:3568
14 	libmozjs.dylib 	js_Interpret 	mozilla/js/src/jsinterp.c:4166
15 	libmozjs.dylib 	js_Invoke 	mozilla/js/src/jsinvoke.c:1313
16 	libmozjs.dylib 	js_InternalInvoke 	mozilla/js/src/jsinvoke.c:1369
17 	libmozjs.dylib 	JS_CallFunctionValue 	mozilla/js/src/jslong.c:5054
18 	XUL 	nsJSContext::CallEventHandler 	mozilla/dom/src/base/nsJSEnvironment.cpp:1962

Filename 	Version 	Debug Identifier 	Debug Filename
libSimplifiedChineseConverter.dylib 		548D5A699DBE2BB8FCC8275321FDC0D40 	libSimplifiedChineseConverter.dylib
PlaxoABAddIn 		0D81DFCA479BDB017739503643E2AF580 	PlaxoABAddIn
libFontStreams.A.dylib 		7A17A98F1526D5AC1F34408E24AA07D40 	libFontStreams.A.dylib
DictionaryService 		8EDC1180F52DB18E9DDFB4E95DEBE61B0 	DictionaryService
Unicode Encodings 		542F2B8930D6BDF16C318FFEA541ACAB0 	Unicode Encodings
RawCamera 		56067945130800A348EB076676D41E920 	RawCamera
PrintPDE 		4A4500E56B10F5E77F297F84190429730 	PrintPDE
AudioIPCPlugIn 		9CE6F675CE724B0BA4E78323B79CF95C0 	AudioIPCPlugIn
libTraditionalChineseConverter.dylib 		89EC94121EF50601DC538548CAAE57FC0 	libTraditionalChineseConverter.dylib
PrintCocoaUI 		E530093F37BC0D0DF38D65A582494F640 	PrintCocoaUI
PrintingCocoaPDEs 		433092D7600C96B9DCC083CCCBF84F170 	PrintingCocoaPDEs
DellSecurePrint 		1FA358ADCBBCDEA7E9D61901299C594B0 	DellSecurePrint
AppleHDAHALPlugIn 		83A4FB705E2A5DF1E1708406495BCD060 	AppleHDAHALPlugIn
CoreAudioKit 		82F2E52C502DB7F3B32349A54209A0FE0 	CoreAudioKit
DellJobAccount 		8302A88E58B53A7D211DD80ED3BD095E0 	DellJobAccount
libPDFRIP.A.dylib 		FD8AD69C65F95E3E32D44F5ED6EC43FB0 	libPDFRIP.A.dylib
Flash Player 		8355DCF076564B6784C517FD0ECCB2F20 	Flash Player
CoreAudio 		927D0CCA7418A8E040BD043D79C5FCA00 	CoreAudio
HIServices 		F7E78891A6D08265C83DCA8E378BE1EA0 	HIServices
LangAnalysis 		8B7831B5F74A950A56CF2D22A2D436F60 	LangAnalysis
SpeechRecognition 		D3180F9EDBD9A5E6F283D6156AA3C6020 	SpeechRecognition
libssl.0.9.7.dylib 		C7359B7AB32B5F8574520746E10A41CC0 	libssl.0.9.7.dylib
InstallServer 		A0358A24A32E1E9813A1575185B3398F0 	InstallServer
ATS 		A96CD91DABC68545183C11DE8F92C7E40 	ATS
libsasl2.2.dylib 		B9E1CA0B6612E280B6CBEA6DF0EEC5F60 	libsasl2.2.dylib
ApplicationServices 		8F910FA65F01D401AD8D04CC933CF8870 	ApplicationServices
libRIP.A.dylib 		1F09316E876FE813271BDFB9EB5B229E0 	libRIP.A.dylib
AddressBook 		BB7F2D5F0B2D180288CD959CD9BA6C1A0 	AddressBook
Print 		8BF7EF71216376D12FCD5EC17E43742C0 	Print
vImage 		2A2C9E354B6491A892802B0BD97F1CC80 	vImage
libicucore.A.dylib 		3D8FDAF51C2664AB620F1688203CAF260 	libicucore.A.dylib
CarbonSound 		0F2BA6E891D3761212CF5A5E6134D6830 	CarbonSound
CommonPanels 		EA0665F57CD267609466ED8B2B20E8930 	CommonPanels
LaunchServices 		61AF37AAC50984D220DD176F777E3B720 	LaunchServices
libGLImage.dylib 		F0FE2252F6B1CA341BC7837FE2DCF11A0 	libGLImage.dylib
NavigationServices 		91844980804067B07A0B6124310D3F310 	NavigationServices
libLAPACK.dylib 		9B0ED359D604DC6CA6389560C0BC679F0 	libLAPACK.dylib
QuartzCore 		82435993614A3FFF1236BE18F82188BF0 	QuartzCore
ImageCapture 		058C0E3CC75EE8CA86F6D1AD09EF6A0E0 	ImageCapture
DirectoryService 		4B81063DF189BC462F012A169474FCBC0 	DirectoryService
AppKit 		4C7AF9B12C894D4A528FDA29377F143B0 	AppKit
libCGATS.A.dylib 		973C01CC14F3D673270E269CCFAEC6600 	libCGATS.A.dylib
CarbonCore 		5682AAE1E2CF5AE750D5A4DEA98C084C0 	CarbonCore
CoreVideo 		001910004257F1386724398F584B30B50 	CoreVideo
libRadiance.dylib 		8A844202FCD65662BB9AB25F08C45A620 	libRadiance.dylib
Security 		F01D6CBD6A0F24F6C13952ED448E77D60 	Security
libxml2.2.dylib 		1BAEF3D4972EE789D8FA6C1FA44DA45C0 	libxml2.2.dylib
CoreServices 		2FCC8F3BD5BBFC000B476CAD8E6A3DD20 	CoreServices
libSystem.B.dylib 		A12F397ABF2285077B89BD726BFF5B180 	libSystem.B.dylib
ImageIO 		6A6623D3D1A7292B5C3763DCD108B55F0 	ImageIO
CoreFoundation 		E2869AD6DC1DD289F21B305B0BEA91580 	CoreFoundation
DictionaryServices 		AD0AA0252E3323D182E17F50DEFE56FC0 	DictionaryServices
AudioToolbox 		A4D35F9ABDE6B61E21B40675AB4E5B2B0 	AudioToolbox
Backup 		60FDC2CDE17C2689677F2DCFD592407D0 	Backup
AudioUnit 		880380CB87BE2B31914A5934EB3BA6BA0 	AudioUnit
vecLib 		274CA63B852C0701F86FDB679198FDDB0 	vecLib
OpenGL 		DB835AEB1FFCA9F5B5647DD0829A5B2C0 	OpenGL
CoreUI 		676FAF4FF6DDDBDD7D716FCE0E59349A0 	CoreUI
libmathCommon.A.dylib 		D75DC85A7C3CA075A24E7252869B76600 	libmathCommon.A.dylib
CoreText 		1F1A97273753E6CFEA86C810D62776800 	CoreText
AGL 		AEAB67EF267F8295AE80FDDC197B52A50 	AGL
QuickTime 		87077CEC43C7E9B02C8EE80E50B8B81F0 	QuickTime
Shortcut 		057783867138902B52BC0941FEDB74D10 	Shortcut
libsqlite3.0.dylib 		6978BBCCA4277D6AE9F042BEFF643F7D0 	libsqlite3.0.dylib
libGLU.dylib 		7C4BC24ABDD4C859788D6874F906D5190 	libGLU.dylib
libobjc.A.dylib 		7B92613FDF804FD9A0A3733A0674C30B0 	libobjc.A.dylib
SearchKit 		3140A605DB2ABF56B237FA156A08B28B0 	SearchKit
DSObjCWrappers 		EAC1C7B7C07ED3148C85934B6F6563080 	DSObjCWrappers
libvMisc.dylib 		2C407027985293C0B174294688D390650 	libvMisc.dylib
OSServices 		2A135D4FB16F4954290F7B72B4111AA30 	OSServices
Ink 		BF3FA8927B4B8BAAE92381A976FD20790 	Ink
libcrypto.0.9.7.dylib 		69BC2457AA23F12FA7D052601D48FA290 	libcrypto.0.9.7.dylib
PrintCore 		222DADE7B33B99708B8C09D1303F93FC0 	PrintCore
SystemConfiguration 		8B26EBF26A009A098484F1ED01EC499C0 	SystemConfiguration
libGLProgrammability.dylib 		FE1A33D4919C121AAB831AD516DA6A890 	libGLProgrammability.dylib
QD 		B743398C24C38E581A86E91744A2BA6E0 	QD
Carbon 		98A5E3BC0C4FA44BBB09713BB88707FE0 	Carbon
SpeechSynthesis 		06D8FC0307314F8FFC16F206AD3DBF440 	SpeechSynthesis
libz.1.dylib 		5DDD8539AE2EBFD8E7CC1C57525385C70 	libz.1.dylib
libgcc_s.1.dylib 		F53C808E87D1184C0F9DF63AEF53CE0B0 	libgcc_s.1.dylib
libTIFF.dylib 		3589442575AC77746AE99ECF724F5F870 	libTIFF.dylib
ColorSync 		85315FFE04A9F6E42E5AF8DEECDFF1BA0 	ColorSync
Kerberos 		DA7253E3FB7E47E46CB46D47ED320FFC0 	Kerberos
SecurityHI 		2B2854123FED609D1820D2779E2E09630 	SecurityHI
libCSync.A.dylib 		86D2F2E167BA6F74F45A186F5C7F89800 	libCSync.A.dylib
CoreData 		8E28162EF2288692615B52ACC01F8B540 	CoreData
libbsm.dylib 		D25C63378A5029648FFD4B4669BE31BF0 	libbsm.dylib
libauto.dylib 		42D8422DC23A18071869FDF7B5D8FAB50 	libauto.dylib
libffi.dylib 		A3B573EB950CA583290F7B2B4C486D090 	libffi.dylib
DiskArbitration 		75B0C8D8940A8A27816961DDDCAC8E0F0 	DiskArbitration
HelpData 		28D5C89696B963716210925D91D4A26D0 	HelpData
libJPEG.dylib 		E7EB56555109E23144924CD64AA8DAEC0 	libJPEG.dylib
vecLib 		274CA63B852C0701F86FDB679198FDDB0 	vecLib
libstdc++.6.dylib 		04B812DCEC670DAA8B7D2852AB14BE600 	libstdc++.6.dylib
CoreAudio 		70BB7C657061631491029A61BABE0B260 	CoreAudio
Foundation 		5CFA0AA8B9B43193955D601BA6C2591A0 	Foundation
LDAP 		CC04500CF7B6EDCCC75BB3FE2973F72C0 	LDAP
AE 		E01596187E91AF5D48653920017B8C8E0 	AE
OpenScripting 		572C7452D7E740E8948A5AD07A99602B0 	OpenScripting
HIToolbox 		5E2AF960B53059C648AF4ADB994710320 	HIToolbox
libcups.2.dylib 		BDDAA132350E872B9D6D8B7E57F204D10 	libcups.2.dylib
Accelerate 		274CA63B852C0701F86FDB679198FDDB0 	Accelerate
HTMLRendering 		FE87A9DEDE38DB00E6C8949942C6BD4F0 	HTMLRendering
libGIF.dylib 		572A32E46E33BE1EC041C5EF5B0341AE0 	libGIF.dylib
libBLAS.dylib 		3769D952F2378FCA4FCCAA61527C8ACF0 	libBLAS.dylib
libresolv.9.dylib 		A8018C42930596593DDF27F7C20FE7AF0 	libresolv.9.dylib
libvDSP.dylib 		B232C018DDD040EC4E2C2AF632DD497F0 	libvDSP.dylib
libPng.dylib 		4780E979D35AA5EC2CEA22678836CEA50 	libPng.dylib
libxslt.1.dylib 		4933DDC7F6618743197AADC85B33B5AB0 	libxslt.1.dylib
CFNetwork 		C6565C13B0356E1D4BB99A68398D558B0 	CFNetwork
CoreGraphics 		481A77E81D9E53589A05E80CFA90BBB50 	CoreGraphics
DesktopServicesPriv 		D16642BA22C32F67BE793EBFBE67CA3A0 	DesktopServicesPriv
Cocoa 		E064F94D969CE25CB7DE3CFB980C32490 	Cocoa
IOKit 		324526F69E1443F2F9FB722CC88A23EC0 	IOKit
libGL.dylib 		AB2164E7650463E7167B603B325B409C0 	libGL.dylib
Metadata 		A6B676925DD832780DAF991E79ADFEBD0 	Metadata
Help 		B507B08E484CB89033E9CF23062D77DE0 	Help
libJapaneseConverter.dylib 		7B0248C392848338F5D6ED093313EEEF0 	libJapaneseConverter.dylib
libKoreanConverter.dylib 		51586B8D9EF39123FBE6918F12D8285F0 	libKoreanConverter.dylib
Severity: major → critical
Component: General → XPConnect
Keywords: crash
Product: Firefox → Core
QA Contact: general → xpconnect
Summary: Dell 3110 laser printer causes crashes → Dell 3110 laser printer causes crashes [@ XPCWrappedNative::GetNewOrUsed]
Version: unspecified → 1.9.0 Branch
I'm hitting this or a similar one, too: http://crash-stats.mozilla.com/report/index/ce85f937-87bf-4859-a2ff-42b7a2090415?p=1
(keying off of comment 0) several "second print" crash bugs from the era of the bug report, and the year after, were duped to Bug 460963 and Bug 396680.

also no crashes with this signature exist for v3.6 or 4.0 (perhaps the signature morphed?). crashes end at 3.1b3 ref: https://crash-stats.mozilla.com/query/query?product=Thunderbird&version=ALL%3AALL&range_value=16&range_unit=weeks&date=03%2F27%2F2011+05%3A16%3A56&query_search=signature&query_type=exact&query=XPCWrappedNative%3A%3AGetNewOrUsed%28XPCCallContext%26%2C+nsISupports*%2C+XPCWrappedNativeScope*%2C+XPCNativeInterface*%2C+int%2C+XPCWrappedNative**%29&build_id=&process_type=any&hang_type=any&do_query=1
Summary: Dell 3110 laser printer causes crashes [@ XPCWrappedNative::GetNewOrUsed] → Dell 3110 laser printer causes crashes [@ XPCWrappedNative::GetNewOrUsed(XPCCallContext&, nsISupports*, XPCWrappedNativeScope*, XPCNativeInterface*, int, XPCWrappedNative**)]
(Reporter)

Comment 6

7 years ago
Confirmed that this is fixed with firefox 4 on 3 separate machines. 

Running Firefox 4.0
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

6 years ago
Crash Signature: [@ XPCWrappedNative::GetNewOrUsed(XPCCallContext&, nsISupports*, XPCWrappedNativeScope*, XPCNativeInterface*, int, XPCWrappedNative**)]
You need to log in before you can comment on or make changes to this bug.