Remove support for importing from old mork-based formhistory.dat

RESOLVED FIXED in mozilla1.9.3a1

Status

()

Toolkit
Form Manager
RESOLVED FIXED
10 years ago
9 years ago

People

(Reporter: Dolske, Assigned: Dolske)

Tracking

Trunk
mozilla1.9.3a1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

10 years ago
We've been storing form history in a SQLite DB since Firefox 2 (specifically, since bug 324170 landed). The code for reading (and importing) from the old Mork storage (formhistory.dat) is still in the tree. It's a sizable chunk of code, has no test, and shares a common interface with the newer mozStorage based backend.

I'd like to just remove the code for dealing with formhistory.dat, to make it easier to maintain the newer code. This would mean Firefox 1.x users upgrading to Firefox 3 for the first time would not have their form history imported, but I think that's such a vanishingly small number of people that it's not worth supporting forever.
(Assignee)

Comment 1

10 years ago
Created attachment 343785 [details] [diff] [review]
Patch v.1

I also started to remove MOZ_MORKREADER=1 from browser/confvars.sh, but I'm not sure if Places' nsMorkHistoryImporter.cpp might still need it. Probably not worth worrying about.
Assignee: nobody → dolske
Attachment #343785 - Flags: review?(gavin.sharp)
(Assignee)

Comment 2

10 years ago
Oops, mconnor was right -- FF2 didn't use formhistory.sqlite, even though the code had landed. Verified with a 2.0.0.17 build on OS X -- I get a formhistory.dat.
(Assignee)

Updated

10 years ago
Attachment #343785 - Attachment is obsolete: true
Attachment #343785 - Flags: review?(gavin.sharp)
(Assignee)

Comment 3

10 years ago
Maybe for 3.2 or later...
Target Milestone: --- → Future
(Assignee)

Comment 4

10 years ago
Filed bug 466414 to go ahead and remove the unused formhistory.dat backend (but not the importing code).

That means *this* bug will be for removing the Mork importing code at some point in the future.
(Assignee)

Updated

10 years ago
Assignee: dolske → nobody
(Assignee)

Updated

9 years ago
Duplicate of this bug: 340871
(Assignee)

Comment 6

9 years ago
Created attachment 402743 [details] [diff] [review]
Patch v.2

Patch updated to trunk.
Assignee: nobody → dolske
Attachment #402743 - Flags: review?(mconnor)
(Assignee)

Updated

9 years ago
Summary: Remove support for old mork-based formhistory.dat → Remove support for importing from old mork-based formhistory.dat
Target Milestone: Future → mozilla1.9.3
(Assignee)

Updated

9 years ago
Attachment #402743 - Flags: review?(mconnor) → review?(vladimir)
(Assignee)

Comment 8

9 years ago
Pushed http://hg.mozilla.org/mozilla-central/rev/faf866398f17
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Target Milestone: mozilla1.9.3 → mozilla1.9.3a1
(Assignee)

Comment 9

9 years ago
Oops, broke a test. Not sure how I did that. O_o

Pushed fix: http://hg.mozilla.org/mozilla-central/rev/1f0cfbdf428a
You need to log in before you can comment on or make changes to this bug.