When a recurrent task is checked as done, it should not disappear

VERIFIED DUPLICATE of bug 373775

Status

defect
--
major
VERIFIED DUPLICATE of bug 373775
11 years ago
11 years ago

People

(Reporter: mr, Unassigned)

Tracking

Details

Reporter

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1.17) Gecko/20080829 Firefox/2.0.0.17
Build Identifier: Lightning 0.9 build 2008091719

When "Done" is checked on a Lightning recurrent task, the task it is no longer displayed !

It should instead be moved or copied (better) to it's next occurence with "Done" unchecked. Then it will appear again in the right time.

MS-Outlook works like this for years, and this looks simple and obvious.

Currently I can't use recurring tasks, and I do not think that anybody can.


Reproducible: Always

Steps to Reproduce:
1.enter a task, set it recurrent
2.find it in the task list
2.check the box "Done" in the list, or after opening the task.


Actual Results:  
the task do not appear in the list for the next occurrence

Expected Results:  
the task should appear for the next time is was scheduled

MS-Outlook works in the right way for many years/versions.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 373775
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.