Can't print postage on USPS site (looks like problems invoking acroread)

RESOLVED INCOMPLETE

Status

()

Firefox
General
RESOLVED INCOMPLETE
9 years ago
8 years ago

People

(Reporter: craig harmer, Unassigned)

Tracking

2.0 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.17) Gecko/20080829 Firefox/2.0.0.17
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.17) Gecko/20080829 Firefox/2.0.0.17

The US Postal Service web site lets you print mailing labels and even postage (which you pay for with a credit card) from their site.  Unfortunately, it doesn't work for me -- the acroread window with the postage never opens.

Some investigation suggests this is a problem with the way Firefox and Acroread are exchanging the data.

This has been reported elsewhere -- i found a recent post in forums.mozillazine.org:

http://forums.mozillazine.org/viewtopic.php?f=12&t=870325

Reproducible: Always

Steps to Reproduce:
1. go to the USPS web site: https://sss-web.usps.com/cns/landing.do

2. near the top of the page, under "You're shipping label is just a Click-n-Ship Away"  you'll see  "Print a sample Domestic or International label."  Click on "Domestic" (or "International" if you prefer).
	
3. the web site moves to a page titled "Print Shipping Labels", and underneath "Print Verification".  it shows an animation which says "Processing ..." for a little while, which eventually stops.  but no shipping label window has appeared.

4. at the bottom it says "Did your label print correctly?".  if you check "No" it will go back and you can try it again.

5. alternatively, you can click on the link labelled "System Requirements" and it will show that Netscape Navigator 6.0 (or IE 5.0) and Adobe Reader Version 5 are required.  it also has a "test your system" link.

6. you should, of course, have Acrobat Reader installed before you try this.
Actual Results:  
No postage or shipping label appears.

Expected Results:  
I expected acrobat reader to open up with my shippin label so i could print it.

i ran an strace on firefox before i tried to print the labels and have that info.  unfortunately, at 2.5 Mbyte it may be a bit large to attach to the bug report.

i also edited /opt/Adobe/Reader8/bin/acroread, a shell script, so it print debugging output of all the steps that it takes.  i will attach that.
(Reporter)

Updated

9 years ago
Version: unspecified → 2.0 Branch
(Reporter)

Comment 1

9 years ago
firefox invokes acroread, a shell script which eventually invokes the acroread binary.  the script is invoked as (from strace):

11204 11:29:29 execve("/local/bin/acroread", ["acroread", "--display", ":0.0", "
-progressPipe", "3", "-exitPipe", "4"], [/* 96 vars */]) = 0

and it eventual invokes the binary using ("set -x" output):

+ exec /opt/Adobe/Reader8/Reader/intellinux/bin/acroread --display :0.0 -progres
sPipe 3 -exitPipe 4
(Reporter)

Comment 2

9 years ago
Created attachment 342111 [details]
this is debugging output generated by adding "set -x" to the front of the acroread shell script so we can see what it  does while starting acroread binary.
(Reporter)

Updated

9 years ago
Attachment #342111 - Attachment mime type: application/octet-stream → application/text
(Reporter)

Updated

9 years ago
Attachment #342111 - Attachment mime type: application/text → text/plain
This bug was reported on Firefox 2.x or older, which is no longer supported and will not be receiving any more updates. I strongly suggest that you update to Firefox 3.6.3 or later, update your plugins (flash, adobe, etc.), and retest in a new profile. If you still see the issue with the updated Firefox, please post here. Otherwise, please close as RESOLVED > WORKSFORME
http://www.mozilla.com
http://support.mozilla.com/kb/Managing+profiles
http://support.mozilla.com/kb/Safe+mode
No reply, INCOMPLETE. Please retest with Firefox 3.6.x or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.