Save dialog doesn't appear when sidebar has focus

VERIFIED FIXED in M18

Status

()

P2
normal
VERIFIED FIXED
18 years ago
17 years ago

People

(Reporter: sujay, Assigned: cmanske)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3+][p:2])

(Reporter)

Description

18 years ago
using 7/19 build of netscape

1) launch netscape
2) launch composer
3) enter some text
4) give focus in the sidebar window
5) File | Save As

notice the Save dialog doesn't come up...

now give focus back to the editor

do File | Save As again...it comes up this time.

all platforms.
*** Bug 45897 has been marked as a duplicate of this bug. ***

Comment 2

18 years ago
Wrong summary?

Comment 3

18 years ago
Fixed the weird summary.
Summary: Pasting yields "P" char → Save dialog doesn't appear when sidebar has focus

Comment 4

18 years ago
Anthony can you see if this is an easy fix, this may end up being some kind of 
focus notification issue that maybe saari will need to help with
Assignee: beppe → anthonyd
Keywords: correctness
Target Milestone: --- → M19

Updated

18 years ago
Status: NEW → ASSIGNED

Comment 5

18 years ago
ok, so the real problem with this bug is that File Save|File Save As should be 
ghosted when document is not focused.

Anthony

Comment 6

18 years ago
*** Bug 41179 has been marked as a duplicate of this bug. ***

Comment 7

18 years ago
*** Bug 45920 has been marked as a duplicate of this bug. ***

Comment 8

18 years ago
This affects menus in mail compose, etc.  See dups.
Nominating for nsbeta3.
Keywords: nsbeta3

Comment 9

18 years ago
this shold be fixed for beta3
Whiteboard: nsbeta3+
Target Milestone: M19 → M18

Updated

18 years ago
Whiteboard: nsbeta3+ → [nsbeta3+]

Comment 10

18 years ago
setting priority in status whiteboard
Priority: P3 → P2
Whiteboard: [nsbeta3+] → [nsbeta3+][p:2]

Comment 11

18 years ago
Okay, so after discussing this a bit with saari, and others, it appears that the 
correct behaviour is to ghost inappropriate menu items if the document is not 
focused.  Until I hear otherwise, that is the solution I am going to persue.

Anthony

Updated

18 years ago
Depends on: 49376

Comment 12

18 years ago
Charlie has fixed this, reassigning to him so he can close this after he checks 
in.
Assignee: anthonyd → cmanske
Status: ASSIGNED → NEW
(Assignee)

Comment 13

18 years ago
checked in 8/22. Adding controller to main window (fix for 41810) also fixed 
this.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 14

18 years ago
verified in 8/24 build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.