Added in the list of servers known to do bad things with pipelined requests

RESOLVED INVALID

Status

()

Core
Networking: HTTP
RESOLVED INVALID
10 years ago
8 years ago

People

(Reporter: Albert, Unassigned)

Tracking

({mobile})

Trunk
mobile
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322; InfoPath.1)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; ko; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3

Prerequisite configurations are 
/* http prefs */
pref("network.http.pipelining", true);
pref("network.http.pipelining.ssl", true);
pref("network.http.proxy.pipelining", true);
pref("network.http.pipelining.maxrequests" , 6);
pref("network.http.keep-alive.timeout", 10);
pref("network.http.max-connections", 4);
pref("network.http.max-connections-per-server", 4);
pref("network.http.max-persistent-connections-per-server", 4);
pref("network.http.max-persistent-connections-per-proxy", 4);
pref("network.proxy.http","xxx.xxx.xxx.xxx");
pref("network.proxy.http_port",8080);
pref("network.proxy.ssl","xxx.xxx.xxx.xxx");
pref("network.proxy.ssl_port",443);

I have observed that when using proxy server through Vodafone and Samsung Network, I have connected "www.nytimes.com" by i780 Samsung mobile target.
I would never see pipelining while connecting "www.nytimes.com".

It promptly resends information even if it supports HTTP/1.1 and keep-alive.
If you want to receive all data from it's web server, you have to wait for ten minutes to finish the transaction.

I think it is depend on nytimes's web sever under the proxy server.
Nytimes uses  "Sun-ONE-Web-Server/6.1". 

I think that "Sun-ONE-Web-Server/6.1"(formerly Netscape Enterprise Server / iPlanet Enterprise Server) is similar to "Netscape-Enterprise/3".
I assume that "Netscape-Enterprise/3" can not support pipelining.

I suppose that it is added in the list of servers known to do bad things with pipelined requests

I think that it must be added, it's like below

nsHttpConnection::SupportsPipelining() in nsHttpConnection.cpp
    // the list of servers known to do bad things with pipelined requests
    static const char *bad_servers[] = {
        "Microsoft-IIS/4.",
        "Microsoft-IIS/5.",
        "Netscape-Enterprise/3.",
+       "Sun-ONE-Web-Server/6.1",
        nsnull
    };

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Component: General → Networking
Keywords: mobile
Product: Fennec → Core
QA Contact: general → networking
(Reporter)

Updated

10 years ago
Blocks: 458996

Comment 1

10 years ago
pat, can you take a look at this?
Component: Networking → Networking: HTTP
QA Contact: networking → networking.http
I did a simple test of nytimes. It did use Sun-ONE-Web-Server/6.1 but I didn't see any problems with pipelining.

I'm attaching a packet capture taken from the client side. Firefox definitely initiates a pipeline - check out the stream on port 54707 which has up to 3 outstanding requests at a time. All of those requests are served correctly by the Times web site.

Based on that, there does not seem to be a reason to blacklist Sun-ONE.

On the other hand, this trace is from the point of view of the client and we cannot tell for sure how it arrived at the server - there is a slim chance my test did not qualify as pipelining as seen at the server. But it is more likely your problem stems from a broken proxy server rather than the origin. We can't fix that by blacklisting the origin.

I don't have an account with the samsung or vodafone networks. Can you attach a capture of your troubled transaction via their proxy server to this bug - using that we might be able to find the root cause and/or a better workaround.
Created attachment 342251 [details]
capture showing pipelining seems ok

only shows one HTTP stream instead of whole page load due to space considerations

Comment 4

8 years ago
I've also done tests with sites still using Sun-ONE-Web-Server/6.1 (e.g. www.boeing.com and www.samsungmobile.com) and iPlanet, and can't see any problems.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.