UNTIL in RRULE ignored while importing or opening an ics file

RESOLVED INVALID

Status

RESOLVED INVALID
10 years ago
10 years ago

People

(Reporter: btf1, Unassigned)

Tracking

Sunbird 0.9
x86
Windows XP

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3
Build Identifier: 0.9

When I import the following ics file, the event is imported without the end time, ie. the time this event should stop repeating.

Looks like the UNTIL phrase in RRULE gets ignored.

The file itself is an extract from an Outlook export done with outlook2ical.js from ryanwatkins.net

BEGIN:VCALENDAR
CALSCALE:GREGORIAN
VERSION:2.0
BEGIN:VEVENT
DTSTART:20070223T090000
DTEND:20070223T090000
RRULE:FREQ=DAILY;UNTIL=20070304T2359590
LOCATION:
SUMMARY:An event reaccurring in a finished period as exported by outlook2ical.js from ryanwatkins.net
CATEGORIES:(none)
CLASS:PUBLIC
DESCRIPTION:
END:VEVENT
END:VCALENDAR

Reproducible: Always

Steps to Reproduce:
1. Copy the VCALENDAR item to a file
2. Import or open it in Sunbird
Actual Results:  
The event is repeated forever

Expected Results:  
The event stops on March 4, 2007
(Reporter)

Updated

10 years ago
Version: unspecified → Sunbird 0.9

Comment 1

10 years ago
(In reply to comment #0)
> RRULE:FREQ=DAILY;UNTIL=20070304T2359590
                                        ^
looks like there's a trailing '0'; though I haven't had a look at what happens
(Reporter)

Comment 2

10 years ago
You are right. When this 0 is deleted the import works OK.

I assume this should be treated as an invalid input so I close the bug as invalid. But if the project's policy for invalid input is different you might consider reopening it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.