selecting text on some web pages then scrolling makes the browser scroll all the way slowly

RESOLVED DUPLICATE of bug 301399

Status

Camino Graveyard
General
RESOLVED DUPLICATE of bug 301399
9 years ago
9 years ago

People

(Reporter: edjusted, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en; rv:1.8.1.17) Gecko/20080915 Camino/1.6.4 (like Firefox/2.0.0.17)
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en; rv:1.8.1.17) Gecko/20080915 Camino/1.6.4 (like Firefox/2.0.0.17)

If you go to the example URL, scroll down to the bottom of the 1st recipe. Select the text and scroll up while selecting (act as if you wanted to copy just the recipe). Release the mouse button when you get to the top of the recipe. Notice that scrolling will *continue* until it reaches the top of the page, and that it will do so slowly. Also, that window will have control (you can select other Camino windows but won't be able to do anything) until it's done scrolling. This happens regardless of whether or not you're selecting/scrolling up or down.

Reproducible: Always

Steps to Reproduce:
1. select text
2. scroll up/down while selecting
3. release mouse button before reaching top/bottom of page
Actual Results:  
Camino won't release control until it reaches the top/bottom of the page

Expected Results:  
Camino should release control when you release the mouse button

FWIW, could not reproduce in Firefox 3.0.2 for Mac OS X.

Comment 1

9 years ago
I can't reproduce that all in Camino 2.0a1pre.

Comment 2

9 years ago
This sounds a lot like bug 301399, but I highly doubt that bug still happens in trunk since graphics and scrolling performance is so vastly improved.

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 301399
You need to log in before you can comment on or make changes to this bug.